Enabling React results in a blank screen

I just tried enabling the React App from the Flutter UI to see how it compared and all of a sudden I am presented with a blank screen.

I have read through the forum and it seems to suggest there should be a variable in the.env file I can change back to 0 to enable flutter again but I cannot find the variable.

I think I was on 5.5.42 (?) - what file do I need to edit to get my screens back please?


You can run this SQL query to change back to the Flutter app:

UPDATE accounts SET set_react_as_default_ap = 0;

A demo of the React app is available here:

Thank you for your prompt reply - I am now back in business!

1 Like

Hi @Gbetonsnr
cc @hillel

When I change to the react ui, I have also a blank white screen. In my case the react zu works after the following two steps:

  1. php artisan ninja:react within the CLI
  2. https://sub.mydomain.com/update?secret=secret in the Browser

After that the react ui works…

1 Like

can you explain the steps in more detail ?
I would like to try the react ui but its not making sense to me.
I find the file called artisan in the root folder and thats it…

I clicked the button to lauch the react ui and got a blank screen and did the query as @hillel stated above and it worked. But still am interest to test the react UI

@hillel what would be the login details for the demo ?

If you use this link for the React demo you shouldn’t need to provide login details:

Going to that link, it starts off as

> https://react.invoicing.co/demo

and redirects to

> https://react.invoicing.co/login

It may help to try with a different browser.

@david any ideas?

Yep that fixed it.
I tried it in firefox and chrome and it kept on redirecting me to the login screen.

Tried it on Edge and it works fine. Got to the dashboard fine.
Played around with it and it seems just the layout is different. Functionality is the same.

hi everyone, we have made some changes, and have hopefully resolved this issue of switching between the react/flutters, those that are brave can trial it!

We really appreciate feedback!!

I am having issues with the react link redirecting to login and cannot test it out.

Additionally, I am unable to get react app to work for me on my self-hosted installation. I keep getting the infamous white screen of death. I’ve cleared cache, used multiple browsers, and the usual things and it will not work for me.