Web cron 500 internal error

So I dont know why but for some reason the web cron now generates a 500 internal error.

The cron job secret has been setup and been working fine for 1½ year now e.g.
And in env. file: WEBCRON_SECRET=jhkhj78fd44x

Result is currently:

Server log:

I did take a look to in >>> Storage >>> Logs >>> invoiceninja.log / laravel.log but could not directly find any related entry to web cron failure.

Invoice Ninja version:

System Health Check:

Any ideas/ have you guys changed something in the code @david / @hillel ? :thinking:

Thanks in advance!
Kind regards


Are there any details about the 500 error in the web server error logs?

Thanks for your reply Hillel.

No, that is the annoying part. We have partitioned a server by using Plesk CP which we have installed to run various web apps for our company and when when you look in the Plesk server log it just states the error above. (See the screenshot).

Not sure how to provoke it to generate more informative errors for us. :thinking:

One option would be to temporarily set APP_DEBUG to true in the .env file, however in general we don’t recommend using this option in production. If you can cut off public access to you site while it’s enabled it would be best.

Thanks for the suggestion.

Yeah that might be a way I guess.
Invoice Ninja is in production though on our server so we cannot leave that on of hours. But I guess we could do it just for a while and manually run the web cron and se if anything pops up while in debug mode?

We posted a thread too on Plesk forum here: Issue - 500 internal server error [How to find more information about it] | Plesk Forum and waiting for a response from them too. Maybe there is way to force Plesk to generate more informative errors?
We’ll have to see I suppose…


can you check the main PHP error logs in /var/log/phpx.x to see if it is getting written there? if we can get the error message we can assist best.

Thanks David for your message.

Sure, we’ll check that too and get back with any findings.

Thanks again guys.

So finally I had some time to look into this as the summer is now here. I went to /var/log/plesk-php81-fpm but there is no mentioning about Invoice Ninja.

I’ve enabled debug in the .env file:

Enabling debug doesn’t unfortunately remove the default error splash screen:

and display any more information that could lead you in the right diction or at least give you some kind of lead/clue to what is going south here.

The InvoiceNinja’s site Plesk log looks like this:

I did find this line in the "acess_ssl_log:
83.248.xx.xxx - - [11/Jul/2023:18:31:47 +0200] "GET /webcron?secret=vg45v4grf24 HTTP/1.0" 500 6822 "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36"
But that is the olny place where I can find a reference to the web cron job.

Replace the files that run the cron job with a fresh set of files maybe? OR something else?

I’m a bit out of ideas.
Any suggestions guys @david @hillel?

Thanks in advance!
Kind regards.

hmm weird.

I ended up with running a forced update:

That fixed the issue it seems:

I’m guessing that the files responsible for web cron was corrupted I suppose. Can’t confirm it, but since it is now working it does seem to point that way.

While running the forced update it did end up with an error message:–> “Server Error”.
No specific details.

Is this something I should be concerned with?
Invoice Ninja do seem to be fully operational when browsing through it…

Should I maybe do a manual upload of the installation/ server files from the latest zip here:
Simple URL Shortener ?

Thanks again guys.

If you are seeing this, it sounds like the issue is resolved.

I don’t think there is any need to perform another upgrade / manual file upload if everything is working as expected.

Ok, thanks for the help David.
It is very appreciated. :facepunch: