Update v5.3.63-C76 -> v5.3.64 fails

Hi @hillel , @david ,
lastest update fails with following error:

[2022-03-03 17:01:36] production.ERROR: The "/tmp/v5.3.64" directory does not exist. {"userId":1,"exception":"[object] (Symfony\\Component\\Finder\\Exception\\DirectoryNotFoundException(code: 0): The \"/tmp/v5.3.64\" directory does not exist. at /var/www/hst23/htdocs/domain.com/vendor/symfony/finder/Finder.php:590)

Prior updates on shared hosting worked just fine. The folder is not existing, but I can’t figure out, why. The app-triggered update takes to long as no update-files should be pulled to my installation. Do you have any idea?

The system will attempt to pull the .zip into /tmp and then unpack it. can you check to see whether the .zip file downloaded at all?

Hi @david , the /tmp remains empty while pulling the 5.3.64 update. The tmp is unchanged ever since installtation/updates. Has something changed in update procedure in the latest version? Shared host logs don’t show anything helpful. Webspace is about 8GB left.

@cdahinten nothing has changed on our side.

Are there any errors in the logs?

I also have the same issue
Log shows
[2022-03-05 14:02:31] production.ERROR: The “/tmp/v5.3.66” directory does not exist. {“userId”:1,“exception”:"[object] (Symfony\Component\Finder\Exception\DirectoryNotFoundException(code: 0): The “/tmp/v5.3.66” directory does not exist. at /home/redstonewebdesig/public_html/portal/vendor/symfony/finder/Finder.php:592)
#0 /home/reds

@david , @robsonma1984 after deleting shared hosts /.cache/… folders the update went just fine.

1 Like

I cleared that and now it just come up sever error when i try to update

I found that I just need to update the permissions so that it is completely writable fixed the problem. bootstrap/cache folder.

thanks @xtekrepair I will try this next time the /.cache problem reapears.

Set bootstrap/cache folder to 777 permission and i still get a Server error when I try to update.

You may want to try the folowing URLs append


to the URL and/or Append


followed by your APP_SECRET from your .env

Might this help @david ?

thanks i have tried those but i still get server error

Did you add your .env Secret from that line


to your URL:


otherwise it might be useful to get into contact with your hoster.

You may also need to use the -R option. So:

chmod -R 777 ./bootstrap/cache

Hi yes I Used the Secret from the .env
The Hosting provider will not help as InvoiceNinja is not their product they say to contact InvoiceNinja Support

I cant use the -R option as i am on a shared server and dont have access to any terminal applications to run commands

Is there any way to do a manual Update? can I just overwrite the file’s but keep the .env file?

Yes, that is working:

1 Like

I would suggest then using a web interface to accomplish the recursive permissions changes.
Most shared hosting have this sort of option.

Yes i changed them using the web interface, i tried the update again but this did not fix the issue