Problems with v5.1.14 and also with v5.3.33

I have deployed Invoice Ninja on my Synology NAS (with web station) with quite a few problems.

With version 5.1.14 I have managed to perform the setup but once running the PDFs of the invoices are not generated and if I edit the templates the preview does not come out either as an error 500 appears. I also have an alert informing me that the cron must be enabled. I have searched the forum and I see possible solutions such as changing the phantom to snappdf or things like that but I do not know what to do, as I have it on NAS is not the same as other users who have it on Linux or docker.

I try to force the update from the GUI but I get a server error.

I have tried to deploy the 5.3.33 version but it does not start the setup, it appears a (very large) image of two screens and Chinese cat and at the bottom a message of 500 - Server error.

I am desperate because I can not deploy the application, all are problems :frowning:



I have started everything from scratch.
I have managed to deploy version 5.3.33
I have renamed the .env.example file to .env and was able to start the setup.

But the cron and PDF problems are still present.

What can I do?

Help, similar problem. i also have the screen rendering badly. anyone else seen this?

Are there any errors about the 500 in storage/logs?

The info here may help:

thank you for replying. The log didn’t help. i get the Error 500 when choosing view a pdf.
I’ve tried a clean install of V5.3.33; installed app from app store. all give the same result. Here is my setup. Self-hosted on a Lite-speed server; tested on Safari, chrome. I’ve tried disabling ModSec. Anyone able to help with this setup? TIA

Are there any errors about the 500 in storage/logs?

Can you add


to your /path/to/invoiceninja/.env file, then run

php artisan optimize

then make sure all your file permissions and ownerships are correct. Running

find /path/to/invoiceninja/ \( ! -user www-data -o ! -perm -644 \) -ls

may help finding files with wrong permissions or ownerships (/path/to/invoiceninja needs to reflect your installation, www-data may need to be replaced with whatever your http daemon is running as).

Then retry and lets see what’s in laravel.log.

No 500 reference to be found. this seem to occur after the update. i’m baffled. even with a new clean installation, i get 500 when i view pdf.

xoo, thanks for your advise. I tried following but i’m not technical enough and got lost. the log file doesn’t show any 500 error. i am working on a backup. if i delete .env file will it get regenerated again with correct permissions?

oddly enough, when running the demo on the Invoice Ninja site, it all works fine. so could it be a server issue?

Don’t loose/overwrite your .env file, make a backup copy. It contains keys you don’t want to loose and passwords you’d have to re-enter.

Can you check your http daemon’s log files somewhere under /var/log (names depend on your config and the daemon you use)?

thank you once again. Sorry, i can’t find any log files under var/log only vars/cpanel/styles.

I setup a new subdomain and installed a new V5.3.33.
Installed the app from app store on my mac.
Exported CSV files from my old setup and imported using phpadmin.
Installed Clients, invoices, products. opened my new setup, opened one of the invoice, view pdf…and i get Error 500 again. back to square one. just what is going on?
I checked with support at NameHero. i don’t know where to start to look.

BTW: i also installed a hosted version and View pdf gives me Error 500 again.


I installed version 4.5.46 on my Synology (using Web Station) and everything works correctly.

However in version 5 (any of the ones indicated in the title of the post) appears the message that cron must be enabled and the error 500 when editing the template because in the creation of the invoice the PDF never comes out.

What should I do to:

  • Enable cron.
  • Make the PDF generator work.

Remember that I am using NAS Synology and also I do not have much knowledge of terminal commands (that from Synology I do not know if it is possible)

Thank you

1 Like

Is your installation on a public facing IP address? you’ll need this for the PDFs to generate via PhantomJS.

If you have a white label license you can use our HOSTED PDF generator which doesn’t require a public facing IP address.

In regards to the crons, you may have better luck running via the Web Cron system.

cm84 sorry i have highjacked your thread. I appear to have the same issue as yours.
David, i have exhausted all my efforts and not got anywhere. I’m not a techie so sometime can’t follow some of the suggestions.
i cloned my installation to test and saved the database; tried hosted and self hosted. As much as i like IN, it’s now time to give up and look for alternative as i have wasted so much time finding a solution. there is nowhere else to look. thanks for all your patience help and support. Bye

Hi @david

My installation is on my Synology NAS but locally, it does not go outside, there is no public IP.

I have in parallel version 4 installed and here the PDF works fine.

I don’t know what to do anymore to make it work on version 5.

The Web cron thing, I do not understand, is it something on my NAS? should I install something? is it necessary?

Do you speak Spanish? Also the language may be an obstacle.



The system needs to resolve the http address so your DNS must be configured to resolve.

Alternatively if you have a whitelabel license you can use PDF_GENERATOR=hosted_ninja and this will generate the PDFs for you.

Thank you for your response.

About configuring the DNS to resolve the http… where do I configure the DNS? on the Synology NAS?

On the other hand, I don’t have white label license, at the moment I am testing different billing solutions and then I would evaluate if Invoice Ninja is the solution of choice.

I don’t really know how to solve this.
I have installed version 4 and here the PDF does work.


This will be tricky on the Synology, as most likely snappdf will not work so you will be relying on PhantomJS which requires a public IP address so that Phantom can generate the PDFs.

I have tried changing PDF_GENERATOR=snappdf and I still get error 500 when customizing the invoice.

I have also tried PDF_GENERATOR=phantom I have registered on the web and added the api-key and still the same.

I’m desperate already, I don’t know what to do to make it work.