Problems with new Version 5.9.4 and the new react web app


We recently installed the new version 5.9.4 and we seem to have some problems with it.

  1. It seems we cannot upgrade our installation any more. The most recent version according to Releases · invoiceninja/invoiceninja · GitHub should be 5.9.8 but when I click on “Force Update” the version stays at 5.9.4.
    I don’t see any errors in the logfiles ./storage/logs/laravel.log and ./storage/logs/invoiceninja.log

  2. How do updates work with the new react web app? Because I can’t find a button for it.
    Is this react web app the future of invoice ninja? (It seems to be quite a bit faster)
    Will the old interface be discontinued soon?

  3. I know I can get back to the old interface by setting set_react_as_default_ap = 0 in the accounts table. Is there a way to switch between the two versions without going directly into the database?

  4. Product quantities:
    In the product settings we set it to not show product quantities and to always set the default line item quantity to one. (We don’t deal with product quantities and we don’t show them on the invoices).
    This works fine in the old web interface but when I switch to the new react web app, it still shows product quantity when creating a new invoice and this quantity is always set to zero.


  1. Does this problem affect both apps or only the React app?

  2. There should be an option to update in the React app. We will eventually deprecate the Flutter web app however it will still be available as a desktop and mobile app. OS tools - Free Invoicing Software for Small Businesses | Invoice Ninja

  3. The best option is to install the Flutter desktop app, you can then use the web and desktop apps together.

  4. Feel free to create an issue on GitHub to track this. Issues · invoiceninja/ui · GitHub

In the old flutter app I can click on the “Force Update” Button. Then it loads for about 20 seconds and then the page reloads, but the version did not update. It still stays at 5.9.4

In the new react web app I cannot find a button for updating. When I click on “About” it just shows the version “v14.04.2024.1” and the button for “Health Check”.

Maybe the react app would only show an update button if it detects a possible update?

We have a product invironment and a test installation and on both machines it’s not possible to update the version of InvoiceNinja beyond 5.9.4.

Any idea what could prevent us from getting the most recent version?

1 Like

@david do you have any suggestions?

@plaschke at least yo are not alone

We’ve tagged 5.9.9

There was an issue with the updater being shown in an earlier version, so to update you may need to copy over the latest release files.

I now upgraded to v5.9.9 by simply downloading the tarball again and copying my old .env file into the new invoiceninja folder.
(+ executing vendor/bin/snappdf download for the PDF generation to work)

Now the “Force Update” button is displayed in the react app and when I click on it get the message:

Update Available

A new version of the web app is available

· Installed Version: 5.9.9
· Latest Version: 5.9.4

Showing an older version as the “latest”.

@plaschke I didn’t think they’ve gotten to fixing the regression yet in the updater. As long as it’s displaying that you have 5.9.9 installed, it’s up to date. You may need to manually install the tarball with the new fix, when it’s available.

By the by, next time you should be able to unpack the tarball into your existing directory without having to create one. Because the default .env file ends in example, your perfectly crafted one should not be affected.

I would encourage you to backup your web files prior to doing so, just to make sure you are safe. You can use the following to do so, but do it in a different directory than where you have InvoiceNinja installed.

sudo tar -cpzvf invoiceninja.(date).tar.gz /path/to/invoiceninja/

replace (date) with the current date. Ex: invoiceninja.19.06.2024.tar.gz and replace /path/to/InvoiceNinja with the directory path where you have it installed.

Over time, you may wish to delete or move older versions of the back up and only keep the most recent one or two, as they can be large and take up lots of valuable space on the server.

1 Like

Will the update be fixed at some point? I can’t get 5.9.9 to work at all. Looks like the download link is broken?

No update options from 5.9.4-L158 from the Snap app (yuck) and the React interface has never shown anything. I tried unpacking the .tar file from github but it broke the system and I don’t have time right now to troubleshoot it. Thankful for snapshots that I could roll back to :slight_smile:

I’m a bit trigger shy on updates now since it killed the payment links in the .env file a short time ago.

Thanks for your help.

I would assume so, but the devs will need to confirm that. Supposedly, they fixed the download links earlier this week. I’d avoid the snap personally.

I updated from the tarball a couple of days ago and it’s been working fine for me. What steps did you take to update?

I understand where you’re coming from, I’ve been there too. An update broke my system about 6 months ago and it took me about 3 days of troubleshooting to fix it. Thankfully, I didn’t lose anything. I’ve read other people post on here that you can supposedly do a manual download of the tarball into the directory and then use the updater to perform the update. I’ve never done it that way though. To the point that only once has the update button ever worked for me. Since then, I’ve stuck with manually updating and not had any problems.

If you have it installed on bare metal or a VM, I created this guide to hopefully help others, just because it took me so long to figure it out. Maybe it will help you?


Still no improvement:
The “newest” version 5.10.4 seems to be newer than my recently copied tar 5.10.7

This issue is being discussed in the two following topics as well.