Please help - Client not receiving invoice - link missing from emails


I recently migrated to V5. I have since generated three invoices and emailed them but the clients apparently are not receiving them. What’s the problem? Do I need to do something else to fully leave V4? (I have a message displayed top left screen in v5 saying company not activated).


Emails are disabled as you haven’t activated the company in your v5 installation.
To activate navigate to Settings > Account Management. Free Source Available Invoicing, Expenses & Time-Tracking | Invoice Ninja

Thanks very much for your help. I’ve turned on activation. Anything else I need to do? (you provided a link in your message which points to another procedure.)

You will probably need to re-enter your email configuration into your .env file - as I don’t believe that is carried over in the migration.
The link in my previous message just included a photo guide on activating the company at the bottom of the page, but you should also complete the first step of forwarding your customers from the v4 install to the v5. Unless of course your domain hasn’t changed.

Yes, clearly there’s more I have to do as clients are still reporting problems. Emails are now reaching them, but with a non-functioning link to the invoice.

Perhaps I should have said - I only use Ninja online, in a browser so I don’t think the .env file, etc, stuff applies to me, even if I had the slightest idea what it meant! :slight_smile:

I was told by customer service that I could go ahead and use V5 and if I wanted to could just switch back to using V4. Clearly that’s not the case. Well, it may be the case that I can go back to V4, but in the meantime V5 is not actually working. No point making invoices if you can’t actually send them to the client.

Ah so you’re using the hosted variation? Your post is incorrectly tagged as “Self-Hosted”, you should be able to fix that by clicking on the pencil at the top right of the post and clicking “Hosted”.

What does the link actually lead to in the email? Can you get your client to forward you the email and then you can right click on the button and copy the link?

Ok I now have the forwarded email from the client.

It has the wording ‘to view the invoice click on the link below’ but there is no link.


If anyone out there can point me in the direction of a solution to this I’d really appreciate it.


Please check there is a $view_link variable in the template on Settings > Templates and Reminders.

Thanks for helping. I see it, When I click it this is all I get:

It’s in the advanced features. so that’s presumably why.

Are you using a free plan on the hosted platform?

Are you using a free plan on the hosted platform?


Thanks! @david can you please check that emails for hosted free users always use the default email templates.

Anything I can do to fix this? Should I go back to v4? Would be a shame as I just got the hang of 5 but I have several outstanding invoices.

Anybody out there? :slight_smile:

@david any thoughts. If they’re a free user they should be using the default email templates so this shouldn’t be an issue?

I’m guessing @david is not a regular visitor to the forum?

Anything I can do? As the ability to send an invoice to a client is a pretty fundamental part of any invoicing software, then I’m guessing the fix should be straightforward?


Defaults are set for invoice emails. however none are set for reminders it appears.

Should we just use the default invoice email for the reminder?

If they’re on the free plan reminders shouldn’t be sent