Migration Self Hosted V4 to V5 Hosted

Hello Hilel

Before I type my issue I would like to thank you for Invoice Ninja. I don’t believe you can remember me. But I am a user since 2018 of the free self hosted version. I think I started off on version 3. Then moved to 4. Then you came up to 5. I have installed the system for alot of my friends and busienss associates.

Finally a friend of mine had the requirement to move to version 5.

Here is why…

He had an existing version 4.5.3 for a year now. And recently I have done a woocommerce setup for him.
The idea was to integrate woocommerce to invoice ninja (legacy) but his specific requirement was that when a woocommerce order is created that a quote be created in invoice ninja.

Therefore we paid for a 1 year subscription on make.com (previously integromat) and the reason was that on make there is no scenario available to say when a order is created on woo a quote must be created on ninja. There is only Woo order to ninja invoice.

Therefore we purchased a V5 Hosted. duzigroup.invoicing.co

Here are the issues.

1. Migration issues

I emailed support and they replied with saying I need v4.5 first. So I temporarily installed a v4.5.5, then I exported a json out of the 4.5.34 into the 4.5.5.
Then I used the start migration and inputted the hosted address into the system. After a few minutes I recieved an email stating migration complete. About 2000 invoices etc. However it does not show up on Invoice Ninja hosted. I emailed support again and the response I recieved was that it is showing in your side and I must switch companies. There’s only 2 companies. One is test. And then a untitled company. When I enter the untitled company it says loading data. And is stuck there.

Sometimes it gets unstuck but there’s no data in that company.

Please assist urgently.


Thanks, that’s great to hear!

Are you able to use the network tab in the browser console to see if a request is being processed to load the data?

No. I don’t know where it is.

Here are screenshots from email support

On a side note after migration I went back from enterprise to free plan. Support said it happens. Within 48 hours it went back to enterprise.

See screenshots

I need a successful migration today or tomorrow. Because currently we are not using the system. Next step is integrating make which I also have certain bugs with. But my first step is here.

Here’s another question.

My V is self hosted. My V5 is hosted.

Should I rather have went v5 self hosted also.
Can’t I transfer my V5 Hosted to a v5 self hosted licence? We on a monthly subscription.

Only if that would help the issue. Would it :thinking:

It may help to login to the new v5 web app: https://app.invoicing.co

You can transfer data to/from v5 hosted/selfhosted using the JSON export.

Hi again

Sorry to worry.

I did login. But where are the import/export settings exactly?

The menu is different. Which menu is it under. It’s not under basic or advanced settings.

It’s in the basic settings, the third option from the bottom.

These are the options.

Thanks, it looks like you’re using the React app which may not yet support it. You’ll need to use the Flutter app for now.

If you’re still having trouble with the web app it may help to use the desktop app instead.

OK I was sharp enough to use a url

And I’m at the page. BUT only CSV import allowed.

And on my 4.5.3 and 4.5.5 only json export allowed. When I try any other filetype it gives a 500 error. (which I think was done so users are forced to migrate to V5)

We would NEVER purposefully generate a 500 error, if you can share the error details from storage/logs we can try to help debug it. Note: as mentioned above this may not be supported yet in the React app.

OK I assumed due the error not being fixed in over a year it was purpose. Sorry.

Ever since v5 came out the 4.5 versions I have all do 500 error on export. I will share logs in another post.

I’m going to work on the desktop app just now.

I will make sure to provide feedback once we find a solution.

Thank you :relaxed:

Screenshot 2022-12-27 112735


The desktop app on windows says v4 json is not allowed.

So entirely back to square one. :frowning:

I’m not sure I follow, above you wrote: “Can’t I transfer my V5 Hosted to a v5 self hosted licence?”

You can use the JSON option to transfer data between v5 installs.

What are you trying to accomplish?


We have 4.5.34 Self Hosted. Then I have V4.5 self hosted. So I transfered data across to v4.5 as support suggested do that then Start migration. Did that and didnt work. (First couple Responses).

When i asked if I can convert the v5 hosted to v5 self hosted what I meant was if I install a v5 on my self hosted server and then could I transfer the licence from hosted to self hosted.
Reason is maybe the migration would work then…

Currently I have the following open and these are my errors.

No import export option (you said its the react app) but the direct url (above …settings/import_export) gets me there but there is only CSV option.
Has import/export and all filetypes BUT JSON clearly states only JSON by v4 are not supported.
Desktop WInddows Invoice Ninja
Has import/export and all filetypes BUT JSON clearly states only JSON by v4 are not supported.
It looks exactly the same as the invoicing.co.
Tried mobile also on the app but exact same as desktop app.

My Primary mission is to export all existing data out of my v4.5 into my version 5 hosted.

When you say v4.5 do you mean v4.5.50?

I thought after migrating to v5 you couldn’t see the data and would see a ‘data loading’ message? Are you still seeing that message or do you now see your data in v5?

Now when I click the untitled company. the data loading message appears for 5 seconds then disappears and nothing updates. There is no data.

I am attempting a second migration now with the start migration option again One more try with that and lets see.

Please make sure you’re using the latest available version of v4, currently it’s v4.5.50.

As stated I have a 4.5.5 installed. FOr the last few minutes I am trying to import the exported JSOn from 4.5.46 into the 4.5.5.

I tried 4 times. Everytime it is missing a lot of invoices. It did max about 80%.

Im trying again. If I can get this done properly then I will use the start migration option again and see if that works.