Logo disappeared after upgrade to 5.7.14

In May/2023 I installed whatever was the current version of Invoice Ninja at the time (V5.5 IIRC) using the instructions at Install Invoice Ninja v5.5 on Ubuntu 22.04. I uploaded my company logo, all was fine.

Today I upgraded to V5.7.14 using the upgrade button on the website. After upgrading to V5.7.14 the logo no longer works. If I go to Settings/Company Details/Logo I see a “Delete” and “Upload Logo” but no logo. If I click on Delete I see the default logo next to my company name. If I upload a new logo (I’ve tried logos sized 140x120, 70x60, 700x600, 50x50 all png format) then a new file appears in a subdirectory of /usr/share/nginx/invoiceninja/public/storage and the spot next to my company name is empty. Old invoices I generated under V5.5 show my logo, but new invoices do not show it.

I have tried sudo php artisan storage:link since I saw that in another thread, but the result is a message that the link was already created. I removed all the old .PNG from my tests and started with nothing in the /public//storage/xx directory. Still can’t get logos to appear.

I added LOCAL_DOWNLOAD=true (was not there before) in the .env file and verified that the APP_URL is correct with https:// and the FQDN. Most of the .env looks like .env_example except for items that need to be changed (passwords, SMTP…).

Does anyone have any ideas on how to get the logo working again?


Are you using the Flutter or React app/do you see the problem in both apps?

Good point, I used Flutter for the first time yesterday before upgrading.

When I changed back to React just now the logo was not showing, so I deleted it, uploaded it again and I saw it working. Then I changed backed to Flutter and the logo is working there now.

Are you able to reproduce the problem?

No, now it is working fine. I can delete the logo and upload it again with Flutter enabled or with it disabled.

Ok, please let us know if the problem returns.

how and where can you enable flutter?

On your Dashboard page look at the top right, there is a little graphic and when you hover over that it says “Switch to Flutter version of the app.” When you are on the Flutter version and on the dashboard then next to “Company Search” you will see a graphic that looks like a rocket ship and next to it a graphic that looks like a nuclear symbol, when you hover over that one it says “Change to the React web app.”

1 Like