Have to clear cache over and over again

self hosted ninja 5.4
php 7.4
i upgraded from version 5.4.xx to lastest 5.4.8.c86
i ran php artisan upgrade several times via SSH
everytime i login have to clear cache of use an icognito browser
otherwise i get a spinning waiting icon
as soon as i close i have to do this over and over again
same on chrome , android app on smartphone , window app , other pc


Are there any errors in the browser console?

There are no errors just a waiting symbol
We have updated from within de application itself with force update.
Just to explain it different but simple.
When we have a working version after clearing cache or using an icognito browser when we duplicate the browser tab we get a circling waiting icon.

Have you checked the browser console?

we have used different pc’s , different browser
same problem on an android smartphone (have to use a fresh browser)

we have a (paid) selfhosted version
Is there a way to get (potential paid) support

Do you know how to check the browser console for errors?

We provide support for free to all users of the app.

Please also check for error on the server in storage/logs

yes we know
but it works after clearing cache en logging in again

Please send a screenshot of the errors on console tab

Thanks, please also send the errors from the console tab in the browser console. The screenshot above shows that there are 2 errors.

@david any thoughts on the PHP error?

I’m not sure that error is related.

Last try… if you’re able to send a screenshot of the browser console errors I can try to help.

console errors

i have to type http://urltoninvo/public/index.php all the time since i work with ninvo 5 maybe otherwise i got a 500 error already

Thanks, that’s helpful.

If you have to add index.php it most likely means mod_rewrite needs to be enabled.

Are new rows of the “Too many arguments, expected arguments” appearing in storage/logs after trying to log in.

there are no more errors in the storage log !
but still not opening without logging in in fresh browser
this is the .htaccess file in the public directory

Options -MultiViews -Indexes
RewriteEngine On

# Handle Authorization Header
RewriteCond %{HTTP:Authorization} .
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

# Redirect Trailing Slashes If Not A Folder...
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} (.+)/$
RewriteRule ^ %1 [L,R=301]

# Handle Front Controller...
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^ index.php [L]
# Blocks Search Engine Indexing Header set X-Robots-Tag "noindex, nofollow"

I updated again on another client however i was already at the latest version it indicated new app available
Now i can login without clearing cache and can duplicate tabs !
thank you very much !

However we still can not login without typing the index.php
Do i have to change my .htacess in the ninja folder of in the ninja/public ?

I suggest asking your webhost how to enable mod_rewrite

mod_rewrite is enabled , but no luck with index.php (wich is not a serious problem)

however problem is back and with clearing cache no temporary solution

We have complete access with our apps on windows and android (…/index.php/api/v1)
everythings works completely normal on the apps !

in the browser there is no (more) way to get the login screen
just an empty white browser
tried different pc/browser already
succesfull php-artisan optimize
did new forced update from within the app

From the browser console logs it looks like you’re seeing a 500 error.

Are new errors appearing in storage/logs after trying to log in?

No errors in the storage logfile
Can not try to login. No login screen in browser. Just a white browser. Apps working ok. Can log in log out in apps.