Difficulty upgrading from 2.6.8 to 2.6.9


My main dashboard says there is an upgrade from 2.6.8 to 2.6.9. I have done one upgrade before which was from 2.6.7 to 2.6.8 - I did it by using the /update/ on the end of the address.

I am self hosting on a local network. After using the /update/ as per the instructions I get the following message:

As you can see, I don’t receive an error message, I however continue to upgrade to the version I currently have. please advise how I might be able to upgrade this build.

Kind regards,

Can you please repost the error you’re seeing.

Hi Hillel. That is the thing, I don’t receive any errors. As the image above shows, I get a successfully completed update. But right behind it, it says “A new version of Invoice Ninja is available. You’re running v2.6.8, the latest is v2.6.9”


We just release v.2.6.11, can you check if you still see the problem.

Morning Hillel. My setup still shows 2.6.9 as the upgradable version available. I tried it one more time and I continue to get the image as in my post #4031

Kind regards,

To be clear, you’re still see v2.6.8 after upgrading v2.6.11?

Which version do you see listed in the footer of the page?

How are you updating the app, self host zip or from GitHub?


Powered by InvoiceNinja.com - v2.6.8

When I log into the dashboard, I see the following as in the image I posted:

A new version of Invoice Ninja is available. You’re running v2.6.8, the latest is v2.6.9

When I try and upgrade by /update/ at the end of my browser address. I have only upgraded once, and that is how I read and was told to do it… It reads as follows:

Successfully completed update - See what’s new in v2.6.8

I cleared the cache as well, before writing this message.

The image above is a single image. That is exactly how it shows at the top of my dashboard/browser after attempting to update.

Is it safe to upgrade by unzipping the version on the website and overwriting everything. I can use that approach if necessary. Is there a tutorial how to do the upgrade? I would like to backup the database and would like to follow the instructions as exact as specified on your website.

Please advice, thank you.

I think I see the problem.

Loading /update only updates the database, you need to first manually copy over the latest version, you may want to make a backup of your datatabase.


So, I backed up the database. I looked up on the internet how to export it.

I then manually updated the files and refreshed the dashboard, it said congratulations on upgrading to version 2.6.11. I clicked on a customer, it loaded, I clicked on invoices and estimates and i got a message “opps looks like something went wrong”.

I ran the /update as discussed earlier, dashboard loads, customers load, but the invoices and quotes do not.

Please check the logs in storage/logs/laravel-error.log

Also, what do you see when you load /update

Hillel, I get a message that says “congratulations on upgrading to version 2.6.11”-- the dashboard loads, I see invoices and activity. However if I click on one of those invoices or quotes, I get an error message.

Ok, thanks. The logs should have more details…

Is it safe to past the entire log into this open forum?

Another option is to enable debug mode in /settings/system_settings

So… is it safe to post the entire log into this open forum?

If you enable debug mode you can just post the single error you see.

ErrorException in FilesystemAdapter.php line 61:
wcroGss7wjIA7peJh8ZVDQSJdZV68Li2.png (View: /Volumes/Web/MAMP/invoicing/resources/views/invoices/pdf.blade.php) (View: /Volumes/Web/MAMP/invoicing/resources/views/invoices/pdf.blade.php)

It looks like it’s a problem with the logo file.

Can you try removing it to see if it helps.