Data migration to another server


I have an invoice ninja installation on a server through softaculous. I now have another server and I want to transfer all my data to the new installation again through softaculous but I haven’t managed to find an easy way.

I tried to copy and paste the db from phpmyadmin without success.

Many thanks in advance.


We recommend using mysqldump to transfer the database, you’ll also want to copy over the .env file.

Thank you. I will give a go and revert.


In regards to migrating to another server … is there a step by step guide written for dummies somewhere?

Things like we recommend using mysqldump to migrate the data, while helpful to someone who knows the ins and outs of mysql, is going to land a lot of people in trouble … hmmm … let me rephrase that have landed keen people in big trouble …

Would be greatly appreciated if there is …



I found this guide online: How To Migrate Invoice Ninja From One Hosting Server To Another - How To - Ravenous Raven Design

I have managed to complete successfully the migration; below are the steps i followed.

I exported the DB form the original destination through phpmyadmin.
I went to the new server and created a new empty database and gave it the name of the exported one.
I then created a new user, same credentials as the exported one.
I imported the db with no errors.
I then installed invoice ninja on the preferred domain name through softaculous.
Finally, I edited the env file to match the migrated DB and the app key.

I hope that helps someone.

1 Like

One slight issue. All the invoices/quotes are generated and printed without the company’s logo despite i have upload it again.

Any ideas?

@david any thoughts?

If you re save the invoice does the pdf update?

It doesn’t work; I even tried creating new quotes and invoices but the logo is missing.

I reapplied the licence just in case without any luck.

This is what it does.

So the reason for this is most like the system cannot resolve the URL to the image path. You can try adding this variable to your .env file


and then attempt to resave.

That solved the issue. Many thanks :slight_smile: