Client Portal unable to view or download PDF, spinning red-black circle

Self-Hosted, installed via Softaculous on a shared server, not sure where to begin.

Happening with version 5.6.31 and 5.7.5 in an existing installation and database as well as a brand new test deployment.

When sending an invoice to a client, client receives email and clicks on View Invoice button, which takes them to the Client Portal successfully, but viewing the invoice (or quote) results in a spinning red-black circle and never proceeds. Unable to view or download their invoice. Generating PDFs on the admin side appears to work without any issues and enabling the option to attach the .pdf to the email works as well. Turned app-debug on but no entries in log file.

Screen shot attached. Any and all help (and patience) is appreciated!

Hi,

Which PDF generator are you using? It may help to change to hosted_ninja if you aren’t already using it.

Thank you for the reply Hillel, I am already using hosted_ninja.

Can you confirm the PDF generator using the health check option in the app?

Also, are there any errors in the browser console and/or the logs in storage/logs?

Sorry - can you please tell me how to do the health check?

Just found the health check option under “About” but it returns a blank white page after a minute or two.

Are there any errors in the browser console when trying to view the PDF in the client portal?

Also, is the app in a subfolder on the server?

Hi, I have exactly the same problem.
The browser sees this error again : Uncaught ReferenceError: Livewire is not defined
The app is in a subfolder with PDF_GENERATOR=hosted_ninja

Hi everyone.

I have the same problem on self hosted. I was hoping it was because I am still on version 5.7.5, and I am waiting for Softaculous to host the update.

My settings are also PDF_GENERATOR=hosted_ninja

Also, Uncaught ReferenceError: Livewire is not defined error . This happens in Chrome and Firefox.

Thank you, everyone.

Maybe this will help:

I can confirm - same errors as listed above regarding Uncaught ReferenceError: Livewire is not defined and I too have been running in a subfolder from my domain. I’m currently trying to figure out how to get a subdomain working in this version of CPanel and the included SSL cert with no success so far. Still not able to do a Health Check in Invoice Ninja.

Hi everybody

In livewire.php I changed the asset url value, with the same results:

‘asset_url’ => “https://mydomain.com/invoicing/app
and I also tried my orginal setting

‘asset_url’ => “https://mydomain.com/invoicing” - > This gives an error " This page doesn’t seem to exist."

It would be great if the problem is just a setting.

Thank you for your help.

I believe this should be corrected in an upcoming release, @ben is that correct?

Thanks for reporting the issue, but it still doesn’t seem to be resolved.
Is this planned?

I can confirm the issue still exists in 5.7.11. I have temporarily edited my invoice/quote email templates with an “I apologize for the inconvenience…” statement and enabled system-wide to attach the invoice/quote PDFs as an attachment. The problem I’m now facing is that this is triggering SPAM filters for my clients and they still aren’t receiving the invoices without a follow-up email saying “please check your junk folder…”

Is there any other information I can provide to be helpful in identifying the cause of this issue? My web hosting plan doesn’t appear to allow me to easily create a working subdomain to try to circumvent the issue, and I can’t install into the root public_html folder, if that would even help. Is there an official channel I need to report this issue? The rest of the software is working wonderfully and I don’t want to sound ungrateful but this is creating a cashflow issue for me since my clients are nervous about not being able to view in the portal what they’re agreeing to pay for.

Is downgrading and maintaining my database an option? If so, what version is this confirmed still working in, when Invoice Ninja is installed into a subfolder?

I too would be ready to go back to a previous version, or give more information if necessary, because it is very disabling. Please help us…

1 Like

@david @ben can you please advise if the app supports being run in a subfolder or if it will be supported in the future?

1 Like

@hillel

I think this forum post has a few solutions for users running in a subfolder:

Good day,

Thank you for the good info @hillel @david The directory I run INinja from is https://mydomain.com/invoicing. I am on 5.7.10.

In Livewire.php I change the settings to:

‘asset_url’ => “https://mydomain.com/invoicing”,

and

‘app_url’ => “https://mydomain.com/invoicing”,

Then, because I do not have SSH access, instead of,

php artisan optimize

I put into the browser the url:

https://mydomain.com/invoicing/update

Then instead of running

php artisan cache:clear

I put into the browser;

https://mydomain.com/invoicing/update?secret=secret I also deleted the files in /invoicing/bootstrap/cache/

When I try to view the invoice ( https://mydomain.com/invoicing/public/client/invoices/4openJpe7A?silent=true ) it says “This page doesn’t seem to exist.
It looks like the link pointing here was faulty. Maybe try searching?”

What am I doing wrong?

Please help.

I can confirm, I too have a similar setup in a subfolder. I tried the workaround/adjustments listed above (but I do have ssh access, and followed the steps) with the same results. Restored my original livewire.php file and put things back the way they were for now.