Client portal customer info remains blank

secret=secret ???


this value = whatever is set for UPDATE_SECRET

the default value is… secret

well, my UPDATE secret key had a value, go figure. Anyhow, I put the ASSET_URL in the .env and updated with /update?secret=supersecret and it did nothing. I have now tried duplicating livewire directories to every sub-directory and also added the ASSET_URL and tried NINJA/PUBLIC, just /NINJA, and /VENDOR. Nothing worked.


I think i can see the issue here:

in config/livewire.php

find the line

'asset_url' => null,

and replace with

'asset_url' => env('ASSET_URL', null),

After that, run /update?secret=secret and then you should be good to go :slight_smile:

1 Like

Its not working but I think it is because ?secret=secretcode is not working.

So I m trying to do it witht he optimize command. I found how to get into my SSH terminal this is what I get:


If I just put: “php artisan optimize” after the # it says command php not found but could be installed. Can you help me with what the command should look like to work? Or is there another way, like a server restart?

You need to first change to the Invoice Ninja application directory and then run the command, it looks like you’re in your home folder.

So I can get into the directory but:

Should it be working?

It looks like PHP may not available from the command line, you may want to reach out to your webhost for advice.

I cant win. :frowning: Using Vultr servers with Pleask. Not sure how it would be blocked. Anyhow, I am at a loss. I will have to wait for Softaculous to repond

The more I look into this, I think plesk is blocking the cron from working too


delete the contents on bootstrap/cache/* this is equivalent to running the /update command

in regards to PHP, you just need to define the full path to the php binary, typically this is something like /usr/bin/php8.0 or similar, from the terminal you could try to run which php it may provide the path if it is defined.

So manually delete all files in the cache folder:

or open each file and delete the contents?

Delete all those files except the .gitignore


Thank you, thank you, thank you!

So the client portal is now loading but when I inspect the page I am still getting warnings. Is this going to be causing me any issues:

   Livewire: Multiple root elements detected. This is not supported. See docs for more information


Are you running Cloudlfare in front of your webhost? I found this comment from the LiveWire forums

Yes, that was the fix. I can’t thank you enough!

I had this same issue. Not only did i set(more like add) the ASSET_URL in the .env file and edited the vendor/livewire/livewire/config/livewire.php url section, but I had to run php7.4 artisan livewire:publish to apply it the front end as php7.4 artisan optimize alone does not apply it 100%. Now the client portal is working as it should and I am able to updated my test account profile info and such with no more errors from inspection. This error resolves my 404 error as well when schedule:run ran base on cron schedule.

I’m hoping this fixes are being applied to future releases of v5 updates as from fresh install I should have had to do all this.


I’ll add the publish command to the github actions so that this shouldn’t be required in future.

Awesome David. Thanks.

for the people that continues to have this errors and has the invoice ninja installed by softaculus the solution is this:
in /config/livewire.php at Livewire Assets URL change this:

‘asset_url’ => “”,
(or https)

in /config/livewire.php at Livewire App URL change this:

‘app_url’ => “”,
(or https)

then do this:
php artisan optimize
php artisan cache:clear

and its done