Cannot add new tasks after update to 5.10.4

Attempting to add a new task results in the following error message:


I’ve verified that php artisan migrate reports nothing to migrate, and tailing the laravel.log produces no error output when this message occurs. The 400 response does show in the docker logs (proxy_1 here is caddy, and app_1 is invoiceninja):

proxy_1         | 01/Jul/2024:19:19:06 +0000 - POST: 400 /api/v1/tasks 83
app_1           | -  01/Jul/2024:19:19:06 +0000 "POST /index.php" 400

Is there any other information I can access to assist in tracking this down?


@david @ben any ideas?

I am facing the exact same issue. any help would be appreciated.I am running v5.10.5-W160

I don’t know if this should be added here or a new topic should be created. Also let me know if I should report a bug on GitHub.

Since upgrading to v5.10.6 the Tasks page is now blank - nothing is visible and you cannot create new tasks. Going back one page, you must do a browser reload for other pages to be visible again.

Edit: I should note that this also relates to the topic that I linked below.

Edit 2: Also of note, only the React web app seems to be affected by this problem - which is what I prefer to use. The IN Flatpak, flutter app displays the Tasks page correctly.

Hello there.

I’m having a similar problem with the v5.10.4.
Actually, when I try to put a new task it shows a 500: Internal Server Error, but, when I take off the “User” and save the task, it works fine. So I don’t think it’s a server error, there’s a problem with the user field.

@LukeGraybill @MyRaged Did you try without an user?

Are there any details about the error in storage/logs?

Hi @hillel ,

On the invoiceninja.log there’s nothing at the time I tested.
On the laravel.log there’s this…

[2024-07-10 09:07:34] production.ERROR: App\Jobs\Task\TaskAssigned::findEntityAssignedNotification(): Argument #1 ($company_user) must be of type App\Models\CompanyUser, bool given, called in /.../app/Jobs/Task/TaskAssigned.php on line 50 {"userId":1,"exception":"[object] (TypeError(code: 0): App\\Jobs\\Task\\TaskAssigned::findEntityAssignedNotification(): Argument #1 ($company_user) must be of type App\\Models\\CompanyUser, bool given, called in /.../app/Jobs/Task/TaskAssigned.php on line 50 at /.../app/Utils/Traits/Notifications/UserNotifies.php:168)


cc @david @ben

Please update to the latest

Hi @david ,

As I mentionned in this post : V5.10.6 reverts back to previous version after page refresh - #3 by cavetech

I can’t update the latest version, it doesn’t show the option for me!

I tried the “force the update” option, but it didn’t change.


I’ve tagged a new release with an adjustment for this.

Similar to @cavetech, it does not display an update being available in the UI. Even when I try to force an update, it still stays on v5.10.4.

@david I have manually updated (via CLI) to v5.10.8 and the same thing happened as before. In the UI, it tells me an update is now available, but when I try to do so, it says Force Update. When I Force Update the installation reverts back to v5.10.4.

The most recent error in my storage/logs is from 2 weeks ago, prior to the timezone fix that you made. There are no other errors since then. I have no nginx errors and no PHP errors either.

I can confirm this behavior on two completely different installations on different hosters.

1 Like

this version should appears as available now

1 Like

Okay, I was able to force update via the mobile app (not near my PC right now) and reloaded and it seems to have upgraded to current. There was still no regular option to upgrade, only by forcing it, did it seem to work.

I can confirm that the 5.10.8 is working with the user on the task.

Thanks @david

1 Like

Yes, I can also confirm that tasks are working again. Thanks for the fix @david.

1 Like