403: Invalid secret

Just installed 5.0.30 release and tried to login but I got “403: Invalid secret”.
It shows that the secret is optional. What am I missing


Can you check if you have a value set for API_SECRET in the .env file?

The only thing I found was right under the Google maps section otherwise, that is the only occurrence of the API_SECRET

I tried different values and also blank after changing the value in the .env file but no dice

Note: if you change the value in the .env file you need to run php artisan optimize

Thank you for that Hillel

php artisan optimize did not work

try removing the .env variable API_SECRET and then run

php artisan optimize

I tried that… Is there a place in the code where I can disable it?

ah, you need to run the artisan command a level down from the public folder.

I was in the Laravel folder where artisan sits. I tried to get it to run in the public folder but it wouldn’t initiate artisan

The screen shots above show the command attempting to be run in the public folder.

Sorry… I ran it then tried the pub folder… Here is the real screenshot…


Is it okay after running the optimize method or you still having the same issue with an invalid secret?

Still have invalid secret after running the Artisan optimizing step

I’m having this same difficulty, unable to login to the mobile app. I’ve tried with API_SECRET= and without, running PHP ARTISAN OPTIMIZE in between. Has anyone found a solution?

Are you using the v5 version of the mobile app?

There is only one version on the iOS App Store, v1.11 and that’s what I’m using. Is there another way to get an iOS version?

v5 iOS app: Join the Invoice Ninja v5 beta - TestFlight - Apple

All v5 client links can be found here: https://www.invoiceninja.org

That works! Thank you!