Zapier down? Or new beta required?

I was just editing a Zap that has been running for months, then got this error when trying to turn it back on? What changed here and how do I fix it?

authentication failed: Could not locate the bindings file. Tried: → /var/task/node_modules/zapier-platform-legacy-scripting-runner/node_modules/deasync/build/deasync.node → /var/task/node_modules/zapier-platform-legacy-scripting-runner/node_modules/deasync/build/Debug/deasync.node → /var/task/node_modules/zapier-platform-legacy-scripting-runner/node_modules/deasync/build/Release/deasync.node → /var/task/node_modules/zapier-platform-legacy-scripting-runner/node_modules/deasync/out/Debug/deasync.node → /var/task/node_modules/zapier-platform-legacy-scripting-runner/node_modules/deasync/Debug/deasync.node → /var/task/node_modules/zapier-platform-legacy-scripting-runner/node_modules/deasync/out/Release/deasync.node → /var/task/node_modules/zapier-platform-legacy-scripting-runner/node_modules/deasync/Release/deasync.node → /var/task/node_modules/zapier-platform-legacy-scripting-runner/node_modules/deasync/build/default/deasync.node → /var/task/node_modules/zapier-platform-legacy-scripting-runner/node_modules/deasync/compiled/12.22.4/linux/x64/deasync.node


We recently made the v5 integration public which required making the v4 integration private which could be related. You can join the private v4 integration using this link. It may also help to recreate the zap.

Tried the private link + the old API token = same error as before.

Copied the zap, switched to the new beta v5 zapier App, created a new API key for “Zapier 2”

Get this error:

We hit an error adding your new account

authentication failed: Your API token is not valid, please check the value in Invoice Ninja on Settings > API

Not sure what to due next but this is a major zap thats down right now.

To use v5 you would need to first migrate on Settings > Account Management.

You may want to reach out to Zapier directly for advice.

Cant upgrade to V5 right now due to the changes it would break in training workflows. Please see this 1m video to see what I am seeing.

We received an email from Zapier informing us they “needed to recreate all older lambda runtimes on Node 12 or above to address an SSL issue”. This has broken our v4 Zapier integration. They’ve suggested a change to correct it which we’re looking into.

So the only immediate solution is to upgrade to V5 then is that correct?

Yes, that’s correct. This problem shouldn’t affect the v5 Zapier integration.

Any estimated timeline on getting this resolved? At some point I have to just bite the bullet and switch if its not fixed soon.


The v4 Zapier integration has been deprecated, I suggest changing over to v5.

After switching over, updating all zaps, and testing. I believe I found a bug with the invoice number not working when created an invoice via zapier.

Please see here - Screen Recording 2021-10-04...

Can you check the pattern is correct in the settings on Settings > Generated Numbers

There is no pattern, I dont want a pattern. Prior on V4, I would just name the invoice whatever I wanted which is what I need.

Are you specifying the invoice number in the Zap?

cc @david

Correct, the zap is attempting to name the invoice but that part isnt working.

Understood, thanks. We’ll look into it.

The “new payment received” trigger in zapier also does not seem to be working. In a test, it cant find any payments even after immediately putting one through.

I’m having the exact same issue here. Wondering if by migrating to v5 if it would impact our endpoint subscriptions?

are there any sample outputs to confirm Zapier is setting the ‘number’ field?

In v4 it set the Invoice number field without issue. In V5 it does not at all.