Zapier and Invoice Ninja (zap randomly stopped working)

Hey guys,

I’ve been using a zap to generate POs, and it’s been working flawlessly for the last couple months. All of a sudden today it stopped working. Could this indicate an issue with the API or?

Here’s the gist of it - updated invoice triggers find invoice > find client > update google spreadsheet. This updates a spreadsheet with client info, and then all relevant info from the invoice (products, quantities, SKUs).

Here’s the weird part. When the trigger occurs, it’s still updating the spreadsheet with client info, it just won’t update the other relevant info from the invoice. Also, it DOES update all of this info (products, SKUs, etc) when I run a test in Zapier. It just doesn’t perform in real life anymore.

Why would this Zap randomly stop working after it’s been running great for months? Please advise. Thanks!


Where exactly is the zap failing? It may help if you can share the data in/out from the logs.

None of the tasks are actually failing. In Zap history, for the task that is updating google spreadsheet with values from Invoice Ninja:

column A is shown with all client info. In contrast, this is what’s shown in my other columns for invoice info:

There is nothing here to indicate that it’s retrieved appropriate data.

With data out, it does show details in these columns, though this data is not correct, and it doesn’t match the data for the invoice number shown:
|COL$C:|Victron BMV 712,Victron MultiPlus-II 3000VA 12-Volt/120-Volt x 2 Pure Sine Wave Inverter 70 amp Battery Charger,Victron Digital Multi Control 200/200a GX,Victron Energy Cyrix Intelligent Battery Combiner 12-24v (120a),Phoenix Charger 12/50 (2+1) 120-240V,Phoenix Charger Control,Interface MK3-USB (VE.Bus to USB),RJ45 UTP Cable 1,8 m|

Is it possible you were using the “Get Invoice” command rather than “Find Invoice”? If that’s the case changing to find invoice may help.

We deployed a new Zapier release earlier today, that’s the one change which could be related.

No, I’m using “Find Invoice” command. Is it possible to roll back that Zapier update to see if this had an effect? I’ve literally changed nothing about the Zap or the spreadsheet it’s sending information too. I can run another test to confirm whether or not your Zapier release is the culprit.


We can’t roll it back but you may be able to recreate the zap using the previous version to test.

How would I do this? Can you guys test this? Zapier integration is one of the main reasons I signed on for Invoice Ninja. Since you don’t have an easy way to generate POs, I created a work around. This saves my company hours of work each day and significantly reduces any chance for errors in the process of creating POs.

Since this zap worked perfectly before the update, and now it doesn’t work, this seems suggest plausible cause. I’ve already spent hours trying to troubleshoot this. I’d greatly appreciate the support of your team on this.


I’ve found a fix.

Originally I had selected “Data line items” as shown here:
Screenshot 2022-04-13 172334

These items would not populate data when running tests, so I went back into these sections and actually couldn’t find any options with “Data” in the title. So I replaced them with items that did not have “data” in the title, and everything is working again.

Hopefully future updates don’t break other zaps…

Glad to hear you were able to get it working, thanks for sharing the solution!