Windows app showing IN logo despite active license

Hello. I’m using the desktop app v5.7.35-W125 (not through the Microsoft webstore). I’m seeing the Invoice Ninja branding in the PDF’s that get emailed to clients. I have an active whitelabel license. This only happens if I send the email through the desktop app. If I send it through the web browser, it does not show up!

I tried to look for an update, but it seems I can’t find the download for the non-microsoft version of the app. Has it been removed? Is my only option to install it from the store now? Please advise. Thank you!

Edit: It was installed from the Microsoft store but it said “Get” and not “Open” which created the confusion.


I’m not sure how to explain this.

  • The PDFs are generated by the API backend, the app you’re using shouldn’t make a difference.

  • The Windows app has only ever been available through the Microsoft app store.

Yes, I just noticed the app is indeed installed through the Microsoft store. I created a fake client and sent the invoices to that email and can see the watermark in one PDF but not the other.

Maybe the invoice was created before the license was applied? It may help to resave the invoice to regenerate the PDF.

I’ll do that but that’s not the case. It’s all new invoices and the license has been renewed back in Feb 2023 and it’s active till Feb 2024.

@david do you have any ideas?

It’s fixed. Reinstalling the Windows app must have did the trick. When I searched for the IN app in the Microsoft appstore, it said “Get” instead of “Open”. The app version is still the same though. WEIRD!

Glad to hear it, thanks for the update!

It’s mb, sorry for wasting your time! I should have reinstalled the app before posting :man_facepalming: