Windows app fails to launch on Windows 11 22H2


I upgraded my Windows 11 installation to 22H2 recently and I can no longer open the IN Windows native app, it just never launches when clicked on it. I tried uninstalling/reinstalling from the Windows Store but it didn’t fix it.

Any help would be appreciated!



I’m not sure, are there any error details?

No, I just see the spinning wheel for half a second and then nothing! It never launches.

Are you able to try running the app from the command line? It may show more details.

I could try that, sure! What would be the command line?

OK nevermind, I found it. So I typed

explorer.exe shell:appsFolder\InvoiceNinja.InvoiceNinja_4m5t6jv56yafy!invoiceninjaflutter

in Powershell and nothing happened, no error message, just the loading wheel and then nothing.

1 Like

The app stores the local app state in an invoiceninja folder, it may help to try deleting it.

You can also try running the app as an administrator.

When uninstalling the app, the install folder C:\Program Files\WindowsApps\InvoiceNinja.InvoiceNinja_5.0.88.0_x64__4m5t6jv56yafy

gets automatically deleted. Is there any other folder I should be aware of to try to delete it?

In that same folder, after reinstalling the app through the store, I tried right clicking it and running as administrator, but it failed to load then too.

There should be an invoiceninja folder inside your user’s documents folder.

I don’t see any folder of that name in my documents folder! I tried running a search for “invoiceninja” and found some temporary files linked to company state and such, but deleting them didn’t seem to do anything to fix the issue.

Thanks for trying to debug, sorry I don’t have any other advice.

Curious to know if anyone else see this problem.

No problem :kissing_closed_eyes:

We’ll soon see! Windows 11 22H2 was “early access release candidate” or something like that, but it will soon be rolled out at large.

Debugging a different Windows crash the info from the Windows event viewer was helpful, maybe it will help here as well?

Good idea, I forgot about the Event Viewer. Here is the debug info related to the app crash at launch:

- System

|||- Provider

[ Name] Application Error

[ Guid] {a0e9b465-b939-57d7-b27d-95d8e925ff57}

EventID 1000

Version 0

Level 2

Task 100

Opcode 0

Keywords 0x8000000000000000

|||- TimeCreated

[ SystemTime] 2022-07-29T13:42:00.8957799Z

EventRecordID 1305


|||- Execution

[ ProcessID] 13092

[ ThreadID] 3200

Channel Application

Computer Charles-PC1

|||- Security

[ UserID] S-1-5-21-2893701937-4060195485-2438799908-1001

- EventData

AppName invoiceninja.exe


AppTimeStamp 62c7d452

ModuleName invoiceninja.exe


ModuleTimeStamp 62c7d452

ExceptionCode c000041d

FaultingOffset 0000000000005770

ProcessId 0x6490

ProcessCreationTime 0x1d8a350fa5ea679

AppPath C:\Program Files\WindowsApps\InvoiceNinja.InvoiceNinja_5.0.88.0_x64__4m5t6jv56yafy\invoiceninja.exe

ModulePath C:\Program Files\WindowsApps\InvoiceNinja.InvoiceNinja_5.0.88.0_x64__4m5t6jv56yafy\invoiceninja.exe

IntegratorReportId 8b2401f6-f642-4f9d-b0a8-9e10f93e35a9

PackageFullName InvoiceNinja.InvoiceNinja_5.0.88.0_x64__4m5t6jv56yafy

PackageRelativeAppId invoiceninjaflutter

Also: I don’t know what it means, but between several tries, the ExceptionCode value alternates between c0000005 and c000041d, always one after the other in the same order.

Thanks, that’s helpful!

From some research I think it may be related to the graphics card driver, which could have been triggered by the Windows update.

Hello @hillel,

Since updating to 22H2 I have gone through a couple of graphics driver versions, none of which were installed by the OS. Still, IN fails to launch no matter the driver version.

I still have no idea what is going wrong.


I think this is most likely an issue with the framework we’re using, we’ll need to wait for them to correct it.

I have the same issue. Two different computers running windows 11, doesn’t work on either. I’ve tried uninstalling / reinstalling on both. It never starts and never an error.

1 Like

In addition tried Repair and Reset, no change