"Whoops, looks like something went wrong." While uploading Company Logo


I am trying to upload my company logo which is about 600x600 and whenever I do that I get the error “Whoops, looks like something went wrong.”… I digged for logs and didn’t find much but this but it says is php fileinfo installed which it is php 7.2…

[2019-08-09 01:37:19] production.ERROR: LogicException [0] : /home/markd69/public_html/billing/vendor/symfony/http-foundation/File/MimeType/MimeTypeGuesser.php [Line 130] => Unable to guess the mime type as no guessers are available (Did you enable the php_fileinfo extension?) {"context":"PHP","user_id":1,"account_id":1,"user_name":"Mark David","method":"POST","user_agent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/76.0.3809.100 Safari/537.36","locale":"en","ip":"no haha","count":8,"is_console":"no","is_api":"no","db_server":"mysql","url":"settings/company_details"} []

You’ll need to know your php version (php -v, and only the first two digits matter…7.0, 7.1, 7.2, etc), and the server API (i.e. webserver… apache2, nginx, etc.) and run phpquery -v <version#> -s <webserver> -m fileinfo to see if the fileinfo extension is even installed.

Likely it is, since it’s a default module, but it could be disabled. In that case, you can run sudo phpenmod -v <version#> -s <webserver> fileinfo and restart your webserver.

I installed this using the softaculous installer on cPanel.

In that case, you should have a list of available extensions under “Select PHP Version.” It should be a simple matter of checking it to enable and then restarting the webserver. Although I don’t know why it would be installed but not enabled.

It’s already checked

Wow, sorry to dig up an old thread but I’m having pretty close to the exact same issue under the same conditions. I too installed InvoiceNinja via softaculous on VestaCP and As far as I can tell I have the php versions looking ok. I get an error 500 when attempting to upload a company logo, not matter what size or file type. How can I confirm it’s an issue with PHP?

Are you seeing the seem error message in storage/logs?

Have you enabled the php_fileinfo extension?