White screen after updating docker containers due to lack of space


I tried updating my invoice ninja v5 install via docker (docker down, pull, up). Unfortunately, due to running out of disk space, when the app server started, I got a lot of error message from the app container stating cp: no more space left on the device. I’m assuming that when the container first starts and it checks to see if there’s an upgrade or something and then copies some files, which it was unable to do in my case. Now, I just get an empty response when browsing to my URL, regardless of whether I use any browser or the desktop app. There are no errors in either the laravel or nginx logs.

I’m guessing the fact that the file copying was interrupted is the cause of the issue. Is there any way I can force a re-run of whatever initialisation was done?

Resolved by essentially removing the docker/app folder, thus forcing invoice ninja to reinitialise it. The steps were as follows:

# Remove the docker/app folder
sudo rm -rf docker/app
# Restore the .keep files
git checkout docker/app
# Restore permissions
chmod 755 docker/app/public
sudo chown -R 1500:1500 docker/app
# Now start the container
sudo docker-compose up -d

The app is now up and running again!

I did want to check one thing before I delete the backup - is there anything user-specific in the app folder that I would need to restore?


Glad to hear it’s sorted! To backup the app you need a copy of the database and the .env file. If you’re using the document feature you’d also need the storage folder.

Thanks. What is the “document feature” and where can I find more information about it?

The app supports uploading documents to attach to clients, invoices, etc.

Had the same problem, your solution fixed it for me too, thank you!

1 Like