White Label license not working

I have been using white label licensing for years. I just upgraded the server and now it says it needs a new license. I couldn’t find the old license I had just purchased 6 months ago if I remember right.

So purchased a new license and applied, it says applied successfully, but still lists the plan as self-host (free). I tried many times to re-apply the license and even rebooted. Still no luck.

Is this a bug? I tried to clear the cache, health check says all is good.

Thanks in advance

Hi,

If you’re using the web app it may help to try applying the license in the desktop or mobile app.

I am trying to apply the white label license. I tried both in the web app and desktop. Same result: Plan

Plan
Self Hosted (Free)

Expires On
June 15, 2026

@david do you have any ideas?

Are there any errors / messages in the browser console?

you may want to send an email to contact@invoiceninja.com and advise the IP address of your server. It may be firewalled.

This was working before the last update. I did email and they said my IP was not listed. No errors in the console. It says it applied, but never reflects the license just keeps saying self-host (free). I think I even had a valid license before, but it seems that didn’t work either so I purchased a new one, neither license works. Must have something to do with the new changes noticed the frontend has a different version now than the backend. Is there something that needs to be run or done when you upgraded to the latest version that changed all of that.

@sarsenal

Is the invoice ninja logo appearing on your PDF’s ? If it is, then the whitelabel has been applied correctly, but may not be displaying as such in the interface.

No still has the invoice ninja logo branding

Any idea? have customers deleting invoices because it doesn’t have our logo. This started after the update that change the frontend version. I am updated to the latest version.