Webhook performance - Docker vs Shared Hosting?

Ive done alot of integration with Make.com and Zapier to auto calculate some totals and whatnot. All rely on webhooks, i’ve noticed sometimes the webhooks fire right away and sometime they take 15-20minutes. When im on site and enter information (update invoices) i sometimes have to wait a while for it to trigger, which isn’t ideal.

Im currently running on a shared hosting provider, with cron jobs for “On artisan queue:work --stop-when-empty” every 5 minutes and “On artisan schedule:run” every minute with “QUEUE_CONNECTION=database”

One thing i’ve noticed in my database the jobs table consistently has 20-30 entries, is this normal?

I’m trying to determine if i have something set incorrectly, or if i’m running into server performance issues. If performance is the issue, then i could move my IN to a VPS running docker.

Thank you for the support, its much appreciated!


@david do you have any thoughts?

It sounds like your queue’s may not be running, or could be getting killed by the host if it is consuming too many CPU cycles. I would recommend a VPS for performance and consistency especially if you are using webhooks.

Hey @david I was thinking the same.

Is it possible to migrate to the docker version? If I was to setup the docker containers, import my current database and copy the app files would that work? Or do I need to setup a new instance with docker and import within the app?


Yes, I think the simplest way would be to do a JSON export and then JSON import into your docker instance.

Hey @david

I moved my IN to a docker instance running on a VPS, got everything moved over fine but I need to send out a few invoices. Nothings sending, i believe because in System Health its showing Email: log, i’ve updated the env to smtp. Restarted containers, still no change. Tried the update?secret URL (which i had to create “UPDATE_SECRET=xxxx” in my env) still not updating in System Health or sending, any suggestions?


when you start up the container, are you doing it without the -d flag?


docker-compose up

This will give you full logging to console so it should give you more information.

Also, are you updating the env file in the root of your project?


I was running with -d, i ran without to see what info i would get but it looks like it reloaded the env file. Its showing smtp now and emails are sending.

Webhooks are also sending right away! Thank you for all the support, you guys rock!