V5 Softaculous Install Destroyed My System

Hello, I just tried installing the updated Invoice Ninja on my server via Softalicious and after attempting the install, I ended up getting a server 500 error. I then tried rolling back my server to multiple backups including full, file, and database restores with and without the assistance of my host, however the server 500 error message persists.

It seems that somehow the install altered my server settings so that even my system backups of Invoice Ninja no longer function at all.

My host says I’m getting this error:

[07-Jul-2021 19:33:32 UTC] PHP Fatal error: Uncaught Error: Class ‘Request’ not found in /home/[REDACTED]/app/Exceptions/Handler.php:106
Stack trace:
#0 /home/[REDACTED]/vendor/turbo124/framework/src/Illuminate/Foundation/Bootstrap/HandleExceptions.php(112): App\Exceptions\Handler->render(Object(Illuminate\Http\Request), Object(Symfony\Component\Debug\Exception\FatalThrowableError))
#1 /home/[REDACTED]/vendor/turbo124/framework/src/Illuminate/Foundation/Bootstrap/HandleExceptions.php(89): Illuminate\Foundation\Bootstrap\HandleExceptions->renderHttpResponse(Object(Symfony\Component\Debug\Exception\FatalThrowableError))
#2 [internal function]: Illuminate\Foundation\Bootstrap\HandleExceptions->handleException(Object(Symfony\Component\Debug\Exception\FatalThrowableError))
#3 {main}
thrown in /home/[REDACTED]/app/Exceptions/Handler.php on line 106

Any assistance is apprecaited. I’ve also tried doing an uninstall and reinstall via softalicious however when I did a softalicious install, the system rejected the admin credentials that were created. I also tried resetting via softalicious, had no luck. The password reset functionality did not work at all, and when I try to manually connect the new install to my old database - I get the 500 error again.

Any assistance is appreciated.


v5 is a completely new app, you need to create a new database for it.

Hello thanks for the reply. Is there a way to get the install to accept my admin username and password when installing? I’ve tried installing via the one click install and even when I enter the correct credentials I keep getting an error saying that they don’t match what is on file.

You would need to create a new account in v5, does that explain the problem?

Hello that’s not the issue. My challenge is that I did try creating a new install from scratch multiple times and Invoice Ninja consistently says the credentials I used during setup do not match what’s on file.

I then tried using a password recovery email however the system will not generate those.

You can check the users table in the database to confirm the email address is correct.

There’s info here about enabling emails:


Helo, thanks for the prompt response. Greatly appreciated. I’ll take a look now.