V5.6.30 : Error when uploading documents to expenses


I used to be able to upload PDFs to my expenses without problem, but in v5.6.30 I can’t anymore and I get a message like this:

I tried a fresh (separate) installation from Softaculous linked to a brand new database and I get that error too.

Both subdomains (the main and the test one) were routed through Cloudflare, so I temporarily deactivated it and waited for DNS propagation just to make sure it’s not a proxy issue. Still, I get this when trying to upload:

I managed to upload a file on an expanse on your live demo, but it’s running 5.6.28, so I wonder if the issue is my server or version .30.

Thanks in advance!

Edit: I made sure that the appropriate folders (IN root and subfolders) belong to the right user and group and folders permissions are set at 0755.

Edit 2: I ran several other tests and in the end it looks like Invoice Ninja didn’t like the way my PDF was saved/compressed/encoded or whatnot. I opened it in a PDF editor and I saved it over itself and now it uploads properly.


Problem fixed, but it seems that IN is very picky with something in PDFs…!