V5.5.7 requirements?

Running Ubuntu 20.04 virtual machine self hosted
PHP 7.4.3
I tried to upgrade from 5.4.8 to 5.5.7 from the update window on my invoiceninja site and it failed as it always does. So I downloaded the latest version, extracted then started getting all kinds of errors about php, said I needed 8.1? So I tried to upgrade to PHP8.1 and thats when things went sideways.

I am a handyman by trade and use this for my clients but I do not know enough about PHP to fix it when things get broke. My solution is take snapshot of the VM and when things break, restore snap shot and start over.
I never had these issues with v4 and ran a script I found on the web that ran once a month and updated the program without issue.

So question is, do I NEED PHP8.1 or can I still use 7.4.3?
Also, will the update feature ever work just by clicking the update button or will there always be extra hoops to jump through?



v5.5 requires PHP 8.1, there are more details in the release notes:

The update button should usually work however as is the case here PHP upgrades need to be handled separately.

AHH! I was just looking at v5.5.7 and seen the all informative release notes of “General improvements and bug fixes.”

OK, updated to PHP8.1 successfully I think.
php -v
PHP 8.1.8 (cli) (built: Jul 11 2022 08:29:57) (NTS)
Copyright (c) The PHP Group
Zend Engine v4.1.8, Copyright (c) Zend Technologies
with Zend OPcache v8.1.8, Copyright (c), by Zend Technologies

systemctl status php8.1-fpm
● php8.1-fpm.service - The PHP 8.1 FastCGI Process Manager
Loaded: loaded (/lib/systemd/system/php8.1-fpm.service; enabled; vendor preset: enabled)
Active: active (running) since Sat 2022-08-06 20:10:49 UTC; 6s ago
Docs: man:php-fpm8.1(8)
Process: 62601 ExecStartPost=/usr/lib/php/php-fpm-socket-helper install /run/php/php-fpm.sock /etc/php/8.1/fpm/poo>
Main PID: 62586 (php-fpm8.1)
Status: “Ready to handle connections”
Tasks: 3 (limit: 5209)
Memory: 9.8M
CGroup: /system.slice/php8.1-fpm.service
├─62586 php-fpm: master process (/etc/php/8.1/fpm/php-fpm.conf)
├─62599 php-fpm: pool www
└─62600 php-fpm: pool www

Aug 06 20:10:49 charlie.myvnc.com systemd[1]: Starting The PHP 8.1 FastCGI Process Manager…
Aug 06 20:10:49 charlie.myvnc.com systemd[1]: Started The PHP 8.1 FastCGI Process Manager.

And now my website says
“Composer detected issues in your platform: Your Composer dependencies require a PHP version “>= 8.1.0”.”

So I ran composer update and it looks like everything went fine… But I still get “Composer detected issues in your platform: Your Composer dependencies require a PHP version “>= 8.1.0”.”


In general you want to use composer install instead of composer update but I’m not sure why you’re seeing “Composer detected issues…”.

@david any thoughts?


If you are using NGINX ensure you change the fpm version to 8.1

If you are using Apache, ensure you have enabled the php 8.1module for apache, the error is due to 8.1 not being wired up correctly.

OK, so I think I got it, its running 5.5.7
It ran setup again and now all my data is gone.
How do I restore the database? Or rather, how do I tell IN which database to use?

most likely you are missing the php8.1-mysql package.