V5.3.1 self-hosted Zapier Connection failing [Solved]

I’m trying to connect my self-hosted v5 to Zapier but keep receiving errors. I’ve created a new API Token: Settings > Account Management > API Tokens > Add. In Zapier I’ve tried the regular Invoice Ninja app connect, but when I input my details I receive this:

I tried the invite link I found in a different post, even though Zapier said that there was a “newer” app available. This is the result:

My settings for both the regular and v5.0.9:

Is there some setting I need to enable to allow the API to work? Thanks in advance for the help!

See here, that worked for me:

You need to remove /api/v1

YES! SO, the 5.0.9 version, WITH removing the /api/v1 finally did the trick. Thanks @lucaw and @hillel


I removed it but now get:

We hit an error adding your new account

authentication failed: Got 404 calling GET https://invoice.blahblahblah.com/ping?v2=true, expected 2xx.

I dont see anywhere to click ‘Allow or Accept’ and dont see any popups

I think you may be using v4 which requires /api/v1

When I use /apr/v1 I get the invalid token error.

Did you create the token in v4?

Please respond in a new post and I’ll try to help