V5.1.29 issues so far

  1. Unable to sign in on a mac using safari. there is an error “404 method not support for this route, you may need to add /public to the URL” but i tried safari browser on my iphone 6s and i was about to log in using the same URL without any error see attached image

  2. When I use the Android app to sign in, company logo does not load or reflect. I still see the original invoice ninja logo

  3. I followed the short instruction to turn corn job but I dont think it took effect as the instruction is not clear. I still have the warning triangle.

  4. proxy_set_header Upgrade $http_upgrade; and proxy_set_header Connection “upgrade”; added to my proxy server cause google chrome to show xml error when i login then log out and try to login again. I have to refresh the page to get past this error. does’nt happen in firefox or internet explorer. …am using nginx as load balancer because I have this invoice app on a test server.

I took some time to mess with the installation and so far, installation is straightforward…unless your vhost config is not done well…the vhost config in the tutorial works fine…with ssl included…

try to sign into your invoice setup on a mac computer and you might get the same error


  1. Are you using a proxy? If you use a mac I recommend using the desktop app: https://download.invoiceninja.com/macos

  2. This should be resolved in the next version of the app

  3. Please see the info here: Free Open-Source Invoicing, Expenses & Time-Tracking | Invoice Ninja

  4. I’m not sure about this one

so if i wasn,t using a proxy, i could have signed in via web browser on a mac? I will explore that later by trying to access the it via the direct https://IP:port and see. I will also play around with the corn thing. I think this corn part must be done during the initial setup stage ,maybe. I will try your suggestion too.

in the 5.1.29, I saw something new , which is one time password. what is it for how do i use it? am going to learn about but I just want to ask

You can enable 2FA on Settings > User Details