V5.0.13 on Apache using FTP

I’m trying to install the self hosted version, but I am using FTP. I’m not familiar enough to use the other method described in the install post. I’ve done this in the past with V4 and it worked ok for me.

I downloaded the -release version of 5.0.13 to my computer. I extracted all the files. Then, uploaded the files in their existing structure to my webhost to a new folder /public_html/billing5.

After everything uploaded, i went to domain.com/billing5/public/setup. It showed:

Oops, something doesn’t look right!
Make sure all requirements are satisfied.
Required extensions
mysqli :heavy_check_mark: gd :heavy_check_mark: curl :heavy_check_mark: zip :heavy_check_mark: gmp :heavy_check_mark: openssl :heavy_check_mark: mbstring :heavy_check_mark: xml :heavy_check_mark: bcmath :heavy_check_mark:
PHP version
OK :heavy_check_mark:
Writable .env file
OK :heavy_check_mark:
NPM status
I could not find NPM anywhere. Is it installed? :x:
Node status
I could not find Node anywhere. Is it installed? :x:

I’m not sure where I’m stuck. Is NPM and Node something I need to install separately, or something needed in my PHP settings on my server? Is installing V5 in this method not even supported?

Thanks for any help!

NPM and Node are not required but the setup currently blocks if they aren’t installed, we should have a new release soon with a fix for this.

I have downloaded V5.0.17 and uploaded it to my server.
I visited /public/setup and can see the setup form.
After filling out each section and clicking the TEST button, I get “Oops, looks like something isn’t correct!”.
I have confirmed that my database is setup and ready to go. I can connect to it with other software.
If I click the Submit button, it takes me to a “500 | Error” page.

Other than uploading all the files to my server (maintaining the folder structure), is there anything else I’m supposed to be doing? Do I need to set permissions on any folders? Run any other install before the setup?

Thanks for your help on this!

Are there any details in the logs?

The permissions are described here: https://invoiceninja.github.io/selfhost.html#installing-invoice-ninja

Server Logs? Or is there a log being created in the subfolders?

Also, the instructions you sent above talk about dragging the folders to the web root.
Is it acceptable to be using a subfolder? www.domain.com/billing/?

I’ve also tried a subdomain, https://billing.domain.com. Both methods are coming up with the same errors.

I suggest checking the web server error logs and the application logs in storage/logs

I believe both approaches should be possible

Hillel, I really appreciate your help!
I was able to get the install to work. I was not able to get a successful PDF test though.

Now, I am trying to migrate from V4 to the new V5.
Do the database names/passwords need to be the same for each version?

I run the migration (V4 app) and I get " Whoops, looks like something went wrong."
Are there any other settings I need to change/update before running the migration?

Nice, progress :slight_smile:

The database credentials can be different but the user email/password needs to be the same.

Well, I’m having other issues now. Trying to change anything in V5 I get 500 Errors.
Specifically, if I attempt to add my phone number to my user account, or change the Accent Color. It asks for my password, then shows a 500 error.
Also, I can’t find where to change my user password on V5.

Are there any details about the error in the logs?

There is a ‘Recover password’ option on the v5 login screen.