Updating to 4.5.34 and getting error 500

I just upgraded to version 4.5.34 in preparation for the migration to v5. PHP ver is 7.3.
I checked the logs for errors in storage folder but nothing popped up. I previously tried to update to 4.5.33 and got this problem as well. Rolling back to 4.5.27 seemed to have fixed it.

I’m on shared hosting and checked with my host. They said this error is popping up and it is a scripting issue on the vendor and a composer issue so it’s out of their scope.
/home3/user/public_html/portal/vendor/vlucas/phpdotenv/src/Load in /home3/user/public_html/portal/vendor/vlucas/phpdotenv/src/Parser.php on line 98

I have it installed on a subdomain and have enabled the line from the public folder .htaccess file.
RewriteBase /

Not sure what else I’m missing.


I suggest setting up a phpinfo page to confirm your web version of PHP

I just did. It shows PHP Version 7.3.27

Are there any errors in storage/logs/laravel-error.log

Also, please check for any spaces in the .env file

I checked the .env file. There was a line break on this line with the second ’ going onto the next line.
SERVER_SIGNATURE='Apache Server at websiteaddress.com Port 443

Have moved it back up next to . The other spaces are all contained within a ’ and ’ so those are fine right? Now it shows a 404 error instead.

The storage/logs/laravel-error.log do not show any errors since the update. There are some older errors but those are back in feb. Is that relevant?

Are there any errors in the web server error logs?

Did you make any other manual changes when first setting up the app?

I checked in cpanel, errors and didn’t see anything. Just the ones the tech support mentioned:

Do I need to replace the .env with the .env.example file from the newer version? There are some newer lines that aren’t in the older file like wepay, cloudflare.

No, when upgrading it’s important to keep the current .env file

Ok. I’ve kept the current .env file.

I tried my luck with another tech support, he managed to fix it for me. Apparently an issue with the .htaccess file. He added one and everything is back up now. Thanks for the quick responses Hillel!

Hopefully I’m on my way to a v5 migration now! :slight_smile:

1 Like

Awesome, glad to hear it!

Welcome to v5 :slight_smile: