/update not running the update?

Hello! Wanted to start by thanking you for this software! It’s usually fantastic!

I’m running into an issue while attempting to update from v3.3.1 to

I apologize! It submitted my post before I was finished!

Anyways, I was attempting an update from v3.3.1 to v3.8.1. Based on the instructions from the docs, I downloaded the newest .zip file, placed it in the root of my invoices’ website (i.e. /var/www/invoice.example.com/), then went to invoice.example.com/update. The page loaded for a short time then told me I successfully updated to v3.3.1, but I was already using that version?

I also attempted to update by unzipping the latest zip and placing ninja/ in the root of the website, then running /update, and still no proper update to v3.8.1.

Any help is appreciated! Thank you!

Did you copy the new files over the old ones?

The version is specified in the code here:


So I would copy the files inside of the zip/ninja/* and replace them over the original files in my installation, then run /update?

Correct, you need to copy over the files. You shouldn’t need to load /update, the app should automatically determine that a new version has been installed.

I’d suggest backing up your database and the .env file.

Awesome! Copying the internals of the latest.zip/ninja/* to my installation root worked.

Thanks so much!

Just as a note, I get what you’re saying in the update section of the docs now, but I will admit that I was slightly confused as it didn’t specify to copy the zip or the contents within it. I figured running /update would extract the zip and do that itself.

Glad to hear it’s working!

Thanks for the feedback, we’ll look into improving the docs.

You can also tweak this script to your specific installation. When run, it will check the version you have installed against the latest available, and update if necessary. And if you stick it in a crontab, it will all happen automatically. =)