Update from 4.5.45 to 4.5.46 fail

HI all, I updated my test environment (fortunately!) from 4.5.45 to 4.5.46, the result is a blank page with HTTP error 500.

The only relevant log is Apache error log, that say:

[Thu Nov 25 16:50:10.517880 2021] [fcgid:warn] [pid 26244] [client] mod_fcgid: stderr: Stack trace:
[Thu Nov 25 16:50:10.517889 2021] [fcgid:warn] [pid 26244] [client] mod_fcgid: stderr: #0 /home/wavefront/domains/ninja.wavefront-explore.loc/public_html/vendor/laravel/framework/src/Illuminate/Container/Container.php(752): ReflectionClass->__construct(‘view’)
[Thu Nov 25 16:50:10.517891 2021] [fcgid:warn] [pid 26244] [client] mod_fcgid: stderr: #1 /home/wavefront/domains/ninja.wavefront-explore.loc/public_html/vendor/laravel/framework/src/Illuminate/Container/Container.php(631): Illuminate\Container\Container->build(‘view’)
[Thu Nov 25 16:50:10.517893 2021] [fcgid:warn] [pid 26244] [client] mod_fcgid: stderr: #2 /home/wavefront/domains/ninja.wavefront-explore.loc/public_html/vendor/laravel/framework/src/Illuminate/Container/Container.php(586): Illuminate\Container\Container->resolve(‘view’, Array)
[Thu Nov 25 16:50:10.517895 2021] [fcgid:warn] [pid 26244] [client] mod_fcgid: stderr: #3 /home/wavefront/domains/ninja.wavefront-explore.loc/public_html/vendor/laravel/framework/src/Illuminate/Foundation/Application.php(732): Illuminate\Container\Container->make(‘view’, Array)
[Thu Nov 25 16:50:10.517898 2021] [fcgid:warn] [pid 26244] [client] mod_fcgid: stderr: #4 /home/wavefront/domains/ninja.wavefront-explore.loc/public_html/vendor/larav in /home/wavefront/domains/ninja.wavefront-explore.loc/public_html/vendor/laravel/framework/src/Illuminate/Container/Container.php on line 752

If I turn Debug ON in the .env file this is the result:

Whoops, looks like something went wrong.

(1/1) ReflectionException

Class LaravelCrawlerDetect does not exist
in Container.php (line 752)
at ReflectionClass->__construct(‘LaravelCrawlerDetect’)in Container.php (line 752)
at Container->build(‘LaravelCrawlerDetect’)in Container.php (line 631)
at Container->resolve(‘LaravelCrawlerDetect’, array())in Container.php (line 586)
at Container->make(‘LaravelCrawlerDetect’, array())in Application.php (line 732)
at Application->make(‘LaravelCrawlerDetect’)in Container.php (line 1195)
at Container->offsetGet(‘LaravelCrawlerDetect’)in Facade.php (line 159)
at Facade::resolveFacadeInstance(‘LaravelCrawlerDetect’)in Facade.php (line 128)
at Facade::getFacadeRoot()in Facade.php (line 215)
at Facade::__callStatic(‘isCrawler’, array())in Handler.php (line 57)
at Handler->report(object(ReflectionException))in HandleExceptions.php (line 81)
at HandleExceptions->handleException(object(ReflectionException))

I have always applied upgrades without problems.
I don’t know how to solve


Did you download the selfhost zip or did you get the code from GitHub, maybe you’re missing the vendor files?

Hi, normally i download the code from GitHub and all it works. This time I tried the selfhost zip to, but without lucky. Same result.

If you download the code from GitHub you need to run composer install to install the third party packages. The update may have worked in the past however for this version we updated the framework packages which requires updating the vendor folder.

Thanks Hillel, in the next few days I’ll try

Hi, sorry for this long delay in my answer, I’m very busy.
After a lot of attempts, failed. I successfully update 4.5.45 to 4.5.48 in my local server, after that i moved the updated installation in the production server. I think the problem was in the files and directories permissions.
Anyway, thanks for the support

1 Like