Unit Quantity Column on Invoices

Hi all, I’ve just moved here from QuickBooks and although I’ve gone through the invoice design options etc, there doesn’t seem to be a way to show an Item Quantity column?

Some items I sell can be for 12 units at a time etc, so its important to me to be able to show a unit price, a quantity and total line value (unit x qty).

Is this not featured or am I missing something obvious here?

Many thanks! :slight_smile:


Feel free to create an issue to request the feature:

Note: it’s possible you could use a custom product field but you’d need to manually set the value.

Hi @Techyback

See this default test invoice. It has

  • item price
  • quantity
  • line total

Isn’t that what you are looking for?

1 Like

Thanks for this, yeah, thats all I need - I don’t see it anywhere on my side though, I might be best resetting the invoice design or startin a new template maybe? What do you think is best?

1 Like

Thanks @ecomsilio for helping clarify, this can be configured on Settings > Invoice Design > Product Columns.


I would suggest to check the setting Hillel mentioned and see if a new standard layout shows the column. As fas as I can remember, the quantity column is activated per default. So it should be visible without any changes.

Oddly, I don’t see an option on my side for adding or removing a Quantity field under any of the tabs, including the Product Column? Hitting Reset down in the bottom right of the same screen doesn’t seem to make any changes either. All kinda weird here.

Can you check that the quantity field is enabled on Settings > Product Settings.

1 Like


Do you see the quantity field when you try to create a new invoice?

If not, see Hillel’s post. Then the setting “Show product quantity” needs to be turned on.

1 Like

That was it @hillel Many thanks! :pray:

1 Like

Many thanks @ecomsilio for your assitance. The issue was in the Settings>Product Settings as @hillel suggested. Its all showing/functioning as needed now. Appreciate your help sir. :pray: