Unable to purchase White Label

After I click on “Purchase” button I get this on the next page.

Can you check storage/logs/laravel-error.log for any details about the error

[2018-06-02 21:13:17] production.ERROR: ErrorException [0] : /var/www/ninja/vendor/symfony/http-foundation/Response.php [Line 332] => Header may not contain more than a single header, new line detected {"context":"PHP","user_id":1,"account_id":1,"user_name":"First Last","method":"GET","user_agent":"Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/66.0.3359.181 Safari/537.36","locale":"en","ip":"","count":1,"is_console":"no","is_api":"no","db_server":"mysql","url":"white_label/purchase"} []

I’m not sure… it may be related to cURL.

Another option is to use this link to purchase it and then apply the license manually.


Thank you that worked.

Great to hear, thanks for supporting us :slight_smile:

I suspect this happened because I changed user name and company name and e-mail address. It was working fine before, but I wasn’t ready to purchase yet.

Thanks for the info, I’ll try to replicate it.

I am still not able to purchase White Label license from within my invoice ninja installation. There was a link in this thread to purchase it manually but now it says [LINK REMOVED]

How can I purchase the White Label license now?

my current license expires in 9 days.


It may help to try with a clean install of the app with a copy of your database and the .env file

Isn’t that pretty much what happens every time I update the app? All the files get replaced except for .env

I have updated it several times since it was installed 2 years ago but the problem persists. The problem is either in the database or it’s a bug in my PHP version.

In the past I’ve seen this error if I modify a PHP file and accidentally leave a line break, hence the “new line detected”

I haven’t modified any PHP files. I suspect this happened because I changed user name and company name and e-mail address after the installation. It was working before.

That could also explain it…

So it’s a bug then? I think we should be able to change those things without causing problems like this one.

It could be a bug, you should definitely be able to change these settings.

I’m not sure if it will be fixed in the current version but we’ll make sure this works better in the next version.