Unable to install v5

Nothing noteworthy in the laravel logs for me.

Had some success though.

Installed all the dependencies in that list for snappdf and the PDF test worked!

sudo apt install ca-certificates fonts-liberation libappindicator3-1 libasound2 libatk-bridge2.0-0 libatk1.0-0 libc6 libcairo2 libcups2 libdbus-1-3 libexpat1 libfontconfig1 libgbm1 libgcc1 libglib2.0-0 libgtk-3-0 libnspr4 libnss3 libpango-1.0-0 libpangocairo-1.0-0 libstdc++6 libx11-6 libx11-xcb1 libxcb1 libxcomposite1 libxcursor1 libxdamage1 libxext6 libxfixes3 libxi6 libxrandr2 libxrender1 libxss1 libxtst6 lsb-release wget xdg-utils libgbm-dev libxshmfence-dev

The database test went fine. I’m now stuck on the email test. The settings I have input for my SMTP server are correct but the test is failing.

Great. I had issues with smtp, but it was because of a typo. I don’t know anything about your intended mail setup, but if you use TLS, it’s usually port 587.

Are you trying to install fresh, or migrate from version 4.5?

It’s Office365 direct send.

It’s always the same. domain-com.mail.protection.outlook.com, port 25, TLS optional. No user or password to login as it only allow requests from my public IP to send mail.

Using the same settings on a bunch of other services no problem.

It’s a fresh install.

Ok, if you’re using O365, I would at least try it with TLS, port 587, and log in with some credentials. In my experience it’s more likely to work, and you can change/troubleshoot it later. I used to do more google, so I don’t have a ton of experience lately with Microsoft’s SMTP though.

OK. Thanks. I will have a play with it.

These are the settings from the docs that I always use. I have some entries in my public DNS and also on the exchange server for it to work. I use these settings successfully with other stuff.

I was just going to post that webpage. Do the first option.

Sorry, I was being a div. It’s not the direct send option I use. It’s option 3, the connector option. The settings are the same though.

I tried the first option but had no luck. I think it’s because of 2FA on my login.

I think I need to double-check my connector settings on the exchange server.

Starting to think this may be a limitation of Invoice Ninja itself. Not sure.

It doesn’t seem to even try and send an email unless a username and password are entered. But with the connector setup I have always used, you don’t use a username or password.

OK. I’m in.

I couldn’t get the SMTP test to pass. I just selected “Log” and I’m on the dashboard. Hoping I can figure out how to reconifgure the email settings for my setup later.

Maybe this will help: