Unable to enable modules - please check that Invoice Ninja v5 is installed on the server

When I am trying to enable modules, I get the error below

Error: please check that Invoice Ninja v5 is installed on the server

URL: https://DOMAINNAME/ninja/public/index.php/api/v1/companies/VolejRejNm?

Response: <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>403 Forbidden</title>
</head><body>
<h1>Forbidden</h1>
<p>You don't have permission to access this resource.</p>
<p>Additionally,

Headers: {content-encoding: gzip, content-type: text/html; charset=iso-8859-1, date: Fri, 26 Jan 2024 04:04:37 GMT, server: nginx, vary: Accept-Encoding, x-content-type-options: nosniff, x-xss-protection: 1; mode=block}}

Is there anything I can do or check to fix this?

I have been doing some research, checking the console etc. I get the below error

Hi,

@david do you have any suggestions?

Hi,
Does anyone have any suggestions?

I managed to get around it, i found this post here:

And the person has the same issue/error i did and disabling the mod security worked.
But now shouldnt that be enabled for security ??