Transaction CSV Import issue


When I try to import transactions from my bank, I got the error message “wrong_file_extension”:

I tried with the file extension in upper letter, open it and export it again in csv, but nothing works.
Also, there is nothing in laravel.log for this issue.

I’m in the web version of the app (cannot install app from Microsoft Store).

Any ideas to solve this issue?
Inside the CSV, the column are separated by ;

Many thanks in advance!


The app expects the file to use a comma as a seperator, it may explain the issue.

Are you seeing an error trying to install the app from the Microsoft store?


Thanks for your reactivity!

I tried to replace ; with , in the file, but same error message. I also tried to change the GUI language, but it is not linked to the translation.

No error, but nothing happen when I try to download the app in the Microsoft Store. It’s not linked to Invoice Ninja install, but an issue with the store (I tried everything seen on internet to solve it, but nothing.) I saw that ppl already asked if a .msi would exist in the near future for the app, is it planned or not enought user need it?

What’s the name of the file you’re importing?

It may help to change to the Flutter web app.

We’re looking into making the Windows app available outside the store in the future.

I tried with:

  • ubs.csv
  • export.csv

I switched to the Flutter web app and the issue remain.

To import the transactions in the web app, I went to Transactions > Import.
I tried in Android App, but this option isn’t possible. So in Android, I went to Options>Import/Export and tried to import my CSV → it worked.

Thanks for the details! This could be a bug in the React app. cc @david @ben

Note: if it worked in the mobile app I’d expect it to also work in the Flutter app since they’re basically the same app.

In fact, the Import/export menu in Settings is not available in the web app:

In the Android App, I imported the csv directly from the settings > Import/export

If you switch to the Flutter web app you’ll see the same Import/Export option in the settings.

Perfect. In Flutter that’s work. The problem only occurs in React. Thanks!

Edit: for those who need to switch back to Flutter → You need to change set_react_as_default_ap to “0” in the accounts table.