TimeoutException after 0:00:30.000000: Future not completed


I successfully migrated from V4 to V5 on my shared host provider. I can log in using my browser and the Android app. However, I couldn’t log in from the MacOs app as it was returning this timeout error. I’m running MacOS Monterey v12.1.

After reading similar reports in this forum I found that manually setting the is_large column to 1 in the companies table of the database fixed the problem. I wonder, is there a way to set this flag to 1 without manually altering the database? I tried setting the company size to 500+ from the Company Details but that doesn’t work.

Also, a follow up questions is, why is this setting needed to run the standalone app but not to run the web interface and the Android app?



Can you check if the field is currently set to 0?

You’re correct, that change should only help if you can’t login on any platform.

While is_large was set to 0 I couldn’t login using the standalone app, but using the web browser and the Android app worked well. I then manually set is_large to 1 and only then I was able to log in using the standalone app.

I just checked in the database again, is_large is set to 1, it hasn’t changed. I assume there are no drawbacks on the long run to letting this setting as is.

The main difference is that when is_large is true the data is broken up when first logging in rather than loading it all at once.

Well, in that case I would say that the standalone app has a “digestive” problem because:

  1. The company I use Invoice Ninja for is really tiny, just a handful of clients with one or two invoices per month each. Less than 500 invoices on record.

  2. The Android app works fine when is_large is 0. My cell phone has much less resources than my laptop which has 16 GB of RAM and multicore Intel i7 processors.

With the above, it’s hard to understand why the standalone app wouldn’t work right away. Having to fix up the is_large column in the database manually is not something I would expect a regular user to do.

Anyway, I hope this thread will help other who find the same issue.

Thanks for your quick response!