There was an error saving your invoice error

I am getting this message whenever I try and save an invoice. Any ideas? I’m self hosting.

“There was an error saving your invoice”

What errors are being reported in the error logs?


Where can I find the logs?


I’d also suggest checking the browser console and the web server error logs.

In the console i get:

POST 403 jquery.js:9664
send @ jquery.js:9664
ajax @ jquery.js:9215
ot.(anonymous function) @ jquery.js:9361
onFormSubmit @ create:3896
onsubmit @ create:1090
trigger @ jquery.js:4614
(anonymous) @ jquery.js:5289
each @ jquery.js:384
each @ jquery.js:136
trigger @ jquery.js:5288
ot.fn.(anonymous function) @ jquery.js:8481
submitAction @ create:3861
onSaveClick @ create:3823
onSaveDraftClick @ create:3780
onclick @ create:1408

Are there any details about the 403 error in the web server error log

I can’t actually see an error log on the server in the ninja root folder. where else can i look?

The location can depend on your configuration, you may want to ask your web host.

my host has said: The error log file only populates if your script writes verbose errors, if there’s nothing to error it won’t print to a file

This only happened after I updated to the latest version last week.

OK there is nothing in any error log on the server,.

Which version did you upgrade from?

I assume you’re using an admin user.

What do you see if you load /update (or /public/update) in the browser?


and i get this on /update
The Process class relies on proc_open, which is not available on your PHP installation.

A common error with shared hosting is “open_basedir restriction in effect”, if you see this you’ll need to either temporarily modify your open_basedir settings or run the update from the command line.

I’ve done that and now when i go to /update I get nothing.

However, I still get the same error when saving an invoice

By ‘nothing’ do you mean you see a white screen?

In that case I’d suggest checking the logs for errors.

No it just redirects to login page and says successfully updated.

I can’t see anything in any error logs on my hosting.

Can you try temporarily disabling mod security

OK that’s worked! Is it safe to have mod security disabled?