There was an error processing your payment

A client who has a bank account setup, via stripe API for ACh transfer - just tried to pay and was shown a message on the client dashbaord:

There was an error processing your payment [0]. Please try again later.Message:

* Creating default object from empty value.

looking at the stripe dashboard, it seems she tried a few times and has a “pending” payment in stripe for each.

2 questions

  1. how can i address this so there is no error
  2. how can i make sure she does not get charged 4 times?


@david do you have any suggestions?

looking at the stripe logs, i see 4 posts to /v1/charges that went through without error today, over the last 20 min:


What are the reported errors from stripe? it looks like there are a couple of 402’s which probably mean some missing information. If the client does not have an address or a postal code this could be the issue. You may need to update the customer record within Stripe if the customer has already been created.

As long as the payments have not been completed, Stripe shouldn’t double charge them.

@david those 402 are from weeks ago -not relevant to this issue.

The four 200 ok POSTS for this single invoice, for this issue - do look like they succeed, and my client reached out to me asking why she sees 4 pending charges. so i think something broke on a recent update for ACH payments (in the past she had no issues using this payment method) + ideally invoice ninja would NOT charge the same invoice more than once even in situations like this.

any other insight? i can send the full response body for each of the POST /v1/charges if you need (sensitive info in there so would need a secure way to share or redact most of it)

Hi @tt1011

if you are using 5.3.41 there was a regression that caused the pending payments to not be finalized. this has been corrected in 5.3.42

yes @david my current version is 5.3.41
updating now to help resolve this.
However, the result of this bug is far from ideal, and I continue to loose a bit of faith in the quality of invoice ninja since v5 update…
Can you please point me where in the git repo this bug was addressed, is it here?

This was the fix.