System check: enable the queue

The system check of InvoiceNinja reports that allegedly the cron is not running, although it is active. The message is also displayed when the scheduler is started manually:

php artisan schedule:run
[2022-07-06T15:25:45+00:00] Running scheduled command: App\Jobs\Ninja\QueueSize
[2022-07-06T15:25:45+00:00] Running scheduled command: Callback



The cron and queue are separate things, the queue is set to sync which disables it.

So what to do to activate the queue?

There’s info in the docs:

Hi @hillel,
I know about this doc but I don’t find the bug why “System check” said: “Queue not enabled”.

My cronjob runs every minute php artisan schedule:run
and the workflow for “automatic email” will be enabled:

So why I see the message “Queue not enabled”?

To enable the queue you need to set QUEUE_CONNECTION in the .env to database and add the queue:work cron to process the queued jobs. The details are in the docs.

Note: I don’t believe PHP 8.1 is supported.

@david it’s showing as green in the health check?

The parameter QUEUE_CONNECTION=database in “.env” will be set and both cronjobs are running:

But nothing will be changed in “System check”:

Try running php artisan optimize

Also no change:

Is it possible you have more than one QUEUE_CONNECTION value in the .env file?

No, there is only one:

@david any thoughts?


I would suggest trying to run /update?secret=secret

Also note that we don’t support PHP 8.1 yet.

Hello @david,

i didn’t know that PHP 8.1 is not supported as it is marked OK in the system check

What exactly do you mean by “trying to run /update?secret=secret”?
Is this an entry in the “.env” or a command? What exactly should I do with it?

The same problem with PHP 8.0:

despite the optimize command i don’t think your configuration is updating.

If you add /update?secret=secret in your browser, this will make the system update the configuration also.

Nothing change with domain/update?secret=secret in Browser.
I updated from 5.4.8 to 5.4.9, this will be shown but the problem with queue is the same.