Syntax Error When trying Force Update

I keep gettings this error when I try to force an update.

FormatException: SyntaxError: Unexpected end of JSON input

I have already tried the command:
sudo chown -R www-data:www-data /usr/share/nginx/invoiceninja
But still get the error. Can someone help me?


It may help to increase the PHP memory limit.

Alternatively, you can copy over the latest release zip.

How would I increase the PHP limit?

Also, This is a new install as my last install was corrupted by a server crash. But when I try to activate the install using my old license key, it doesn’t work. How can I generate a new Key?

It can be configured in the php.ini file.

Do you mean to activate the white label license?


Yes, the White Label.
I purchased it back in March. I tried the same license key on the new instance, at first it said activated, but this morning it shows activation issues.
I’m using the same domain, but it’s a completely new build.

Here is a screenshot. It shows the correct expiration date, but says company is not activated

The white label plan is already applied, you may need to toggle the activate company setting.

Yup, found it. for some reason that was unchecked.

Regarding the PHP, I found the file, but what do i increase?

The setting is memory_limit

its currently set to -1
under /etc/php/7.4/cli/php.ini

is that the correct setting and file?

I think that setting is ok, @david any thoughts?

I think i found it.

There was another file under /etc/php/7.4/fpm/php.ini

that was limited to 128m
I’m increasing that to 512m and see what happens

OK. That worked.
I creased that limit and restarted the server and it updated perfectly.

Thank you so much for all your help!!!

Glad to hear it, thanks for the update!