Support of Mollie iDeal payments

Noticed this development on Github. When will this be available on Hosted V5?


We aren’t able to commit to future dates but it shouldn’t be too long.

1 Like

Good news. How do I know that it is available again?

Once it’s live you’ll see an option to enable it in the Mollie gateway settings.

Suggestion. Could you make a thread in this forum where you post release changes to hosted? That way I could be informed of the changes like this.

Can’t ‘see’ it as I switched of online payments as iDeal is the only payments method I’m interested in.

The best way to track changes currently is to follow the releases on GitHub

Does the hosted version get the new releases as they are released?

Yes, usually within a few days.

1 Like

Is iDeal allready there? My desktop app is on v5.3.22-C59.

I read on Github that [5.3.21] includes iDeal Gateway.

But in Settings - Online Payments the iDeal option is missing. Or is it the last option without text (see attachment).?

@david has this been added?


Yes, i think that will be iDeal

iDeal works but has some issues.

The fifth option with no text/title/label is iDeal, but payments description has an character encoding issue.

Suppose I numbered my invoice eg: HAL0100, then I would expect that in the description. But the following gets displayed:

After you click the payments link you get a a screen (see also screenshot) with:
Invoices: [“HAL0100”]

If you scan the QR code you get the description:

And if you click on the payments link and scan the qr code, but don’t pay, you still get two payment confirmation messages. One that you paid and a second one which is referring to completely different invoice number??? So this happens when I start the payment link but don’t end the transaction but keep it open. Then I got the messages. After I got the email messages I checked on my banking app and then I stopped it and got the “Unfortunately the payment failed to complete!” message.

So my questions are:

  1. How can I change/translate: “Invoices:”
  2. Is this a character encoding issue and can you fix this?
  3. Could you check on handling of “leaving before payment”?

Thanks for this. We’ll look into it.

cc @ben

Thanks for reporting this! We’ve pushed fixes for the first two issues, however, we need help on the third one. I cannot replicate it.

Is it possible for you to record the demo of this happening?

I’m trying to replicate it but get several errors from Mollie. Did something change?

I had made a test invoice with a 1 euro product to test it as this was the minimum amount required. This worked before but now I get the error:
{“message”:"[2021-10-13T15:03:49+0000] Error executing API call (422: Unprocessable Entity): The amount is lower than the minimum. Field: amount. Documentation:","code":0}

And when I click on payment link of an invoice I allready generated for a customer I get the message: heeft de verbinding geweigerd.
(translates to: has refused the connection).

That is definitely weird. Can you try more than €1?

Additionally here’s the list of minimum values:

The minimum amount is 1 cent. So my test 1 euro (100 cents) should be above the limit.

Just after the introduction of iDeal support I checked with a 1 euro invoice and then it worked.

Yesterday I tried it with even higher amounts than 1 euro and then it didn’t worked. To be sure I just retried it with 9 euro’s. Still the same error:
{“message”:"[2021-10-14T14:14:14+0000] Error executing API call (422: Unprocessable Entity): The amount is lower than the minimum. Field: amount. Documentation:","code":0}

Maybe related. When I check in the app under Settings-Online payments-System log I get a 500 server error.

So I think it is a bug with your Mollie integration.

Hi, can the current problems have something to do with the fix for the characterencoding? Maybe the commas/(decimal) points?


I’ve tested the implementation in Test Mode. Can you confirm whether you are still seeing the same issue when you set the gateway to Test mode please?

I think the problem is that I tested it by clicking on the link in the “preview” window of InvoiceNinja. I saw that the payment link was the same so thought I could click on it instead of waiting for the email to be delivered. Apparantly there is a difference in clicking on the payment link in my email versus clicking on it in the preview window of InvoiceNinja.

Anyway I tested it with a 1 euro invoice and I could pay. So great it works, but there are some points of attention.

  1. How can I change/translate: “Invoices:” On the Mollie screens and payment description, the invoice number is still preceded by “Invoices:”. Can this be ommitted or at least be translated or modifiable?
  2. Is this a character encoding issue and can you fix this? Solved!
  3. Could you check on handling of “leaving before payment”? Tried to replicate it but couldn’t. Not in test mode too.
  4. Payment failes message (NEW). If payment failed, then there is an email sent. This email refers to “Name”. But “Name” can be empty, in my case if the customer is a private person and not a company. In that case I don’t know which payment failed. So maybe the failed payment mesage should refer also to the customer number or invoice number as this is required.