Stuck in setup loop

I did a migrate:fresh on my db to start over and now i am stuck in a endless loop.

First time I filled out the form i got hit with my email was not valid, it is valid here to my devel server but anyways I got a 500 error with no error message, dug in the logs and it was a lack of memory.

second time i filled out the form, i just got a blank page and nothing else, so i hit refresh and reposed to form. Same thing again a blank page. I go back to the front page and i get redirected back to the setup pag and the redirect ‘fun’ starts all over again.

I have today to get this in a demo format before i have to abandon it. Anyone got any ideas?


A blank white page often means permissions issues, have you checked both the web server error logs and the app logs in storage/logs/

i checked the serve logs, nothing in the laravel log but there was something in the php log. However, it looks to be a stack trace and it is all very hard to read, i have not figured out what the error is.

also, my dev site doesnt have permission problems, a user with permissions creates the files and folders it is the same as the nix server. its a homestead server.

If you can post the error it may help.

By ‘permission problem’ it could be file ownership, this is from the docs:

Ensure the file permission have been set to the web server user. For example in Ubuntu this is www-data if you have configured a virtual host with a root directory of /var/www/html you would set the ownership like this.

sudo chown -R www-data:www-data /var/www/html

I checked the permissions no problem there.

here is the error message, it was too big to post on the forums.

@david do you have any thoughts?

I haven’t seen this one before. what version of PHP are you using?

it may be worth clearing the contents of bootstrap/cache

Clearing the cache did nothing. Running php version 7.4

I did some testing today and figured out a few weird things.

i traced the error down to the Artisan::call(‘migrate’, [’–force’ => true]); this was where it was getting suck, it had problems with the --force not having parameters as best as i can tell. IT still didnt work after removing the --force part. i put debug statements after the migrate call and they were never triggered. it went to a blank page.

the db seed didnt like the force option either for some reason.

next i did both the migrate and seed in a console, and commented them out of the code.

I was able to get to the set up form and fill it all out, but now i have a problem where it says invalid secret, and that is all it says.

Do you know proc_open is supported by the server, it could explain the problem with the migration.

For the secret can you check if there is a secret value set in the .env file.

As far as i can tell it is enabled, and from what i read i would be having issues running command line calls if there was a problem.

I only have API_SECRET and UPDATE_SECRET in the env file

Does API_SECRET have a value?

yes, its applesauce.

Are you supplying the secret in the form?

You may want to try removing it to see if it helps

I put the secret in the form, it made me change it to have a number and a cap letter. still no luck it still says invalid secret.

I also tried removing the env variable.

I am finding the weird that i am having problems installing a fresh copy now.

I think you may be confusing the secret with the password

the login form has email, password, one-time-password, and secret. I am rather sure I am putting the password in the correct box.
but it still says invalid secret.

You may need to run php artisan optimize after removing the secret

clearing the secret and doing the php artisan optimize fixed the issue. I was able to log in and complete the installation.

Thanks for the help