Stripe Payment not showing Pay Now

I’m using a self-hosted v5 invoice ninja.
I have set up my Stripe accordingly, however, I cannot see any pay now button on the invoice.
I double-checked the setting for Online payment: enabled Stripe and included the API keys. I have also enabled: Credit cards, bank transfers and iDEAL in the settings.

A note, when I enable Apple Pay in the setting in Invoice Ninja, it shows at the Pay Now.
Otherwise, nothing works. Very odd.

Thanks for any input.

I cleared the Required Fields (unticked Client Name, etc in Invoice Ninja), then the credit card option is shown in Pay Now. However, the iDEAL payment methods are still not shown.


@david @ben any suggestions?

We use the client country to determine whether specific payment methods are available, most likely this is the reason they are not displaying.

Hey oddly, today it finally works. I deployed invoice ninja in Cloudron. Once the package was updated for some reason it showed now. Very glad :slight_smile:
Or perhaps also, that Stripe requires some account validation. Nevertheless, it works now.
Thanks both for the prompt reply.

1 Like