Strange screen disfiguration in desktop app

I’m running IN v5.5.74 (latest version available in my cpanel) on a self-hosted server.
I have a specific issue in the desktop app - which does not show in a browser window.

While I’ve seen some screen “blurring” before when moving my mouse, with the latest update I made moving from 5.5.64 to 5.5.74 - the blurring becomes now really bad … see


Not sure if this is a IN app issue, or anything going on with my screens/graphics card - though it only occurs with the IN app.

Has anyone else had a similar experience? I know I can always go to a browser window but I typically run the task timer in an app window.


Which version of the Windows app are you using?

You can check using the about dialog button in the lower left corner.

I tried to uninstall the app and reinstall from the MS store - didn’t change anything.
Version says v5.5.74-W109

Btw - the “blurring” gets more and less warped when moving the mouse - from really bad (hard to read) to clean again, depending where I moved over before and where I come to a stop. Funny thing is when I move the mouse over in the white area of the dashboard, the menu area and top menu are gets that blurred look.
It seems to me like an event listener that reacts to mouse movement and redraws the view while moving and doesn’t get it “right”.

When did the problem start?

Note: this problem would’t be caused by updating the backend but may have been caused by an update to the Windows app.

I don’t use it on a daily basis but it was fine a couple of weeks ago - I noticed it specifically when I did invoicing on March 1st.

Yes, I very much assume that this would not have to do anything with the backend version (unless you introduced a method that hasn’t been used before and renders differently in the desktop environment.)

That’s why I uninstalled the desktop app and downloaded it again for a new install. Unfortunately I didn’t check the version I had before but since the behavior didn’t change, I assume it may be the same. Not sure if I the (windows) app auto-updates itself and if I could review an update history. If there was, with the uninstall and re-install the same may be gone anyway.

Do I read the app version correctly as being the code after the software version - i.e. W109?
Is there an option to roll back to an older version?
Also my chrome version says C108 … not sure if web client and desktop client use the same numbering.

I don’t believe it’s possible to rollback to a previous version. Are you able to try testing the app on a different PC to see if you can reproduce the issue?

The next release of the backend will have the matching version, C109.

Good call - installed the app on my surface - no issues there with the same version.

Then tested it back on my laptop taking it off the DELL dock - and it is fine there too on the native display. So it must have to do something with the DP drivers and refresh rate across my multiple screens that seems to specifically show up with the framework IN is using.

Thanks for the pointers - sorry that I bothered you guys with that. It was just that it only showed with that app. Will report back if I find a way to get it fixed from my side.

Thanks for the update!

I was on conference travel the last days so couldn’t further investigate since it only occurs on the three displays connected to my DELL D3100 USB dock. I’ve captured a short video to show how the distortion appears when I move the mouse over different areas of the screen without clicking anything.
It seems to me as the screen refresh rate and the app refresh during mouse movements run interference. What I would like to know is on what platform/framework the desktop app is built so that I could do some research if other apps have encountered similar issues in such an environment. I know this seems to be hardware specific, but it only occurs for me with IN and I’ve already updated all display and display port drivers with no change.
Any pointers are much appreciated!

Thanks for the video! The app is built using the Flutter framework.

I’ve seen there have been some issues with flutter and extended desktop configurations and did some further testing. As I reported earlier, I didn’t have the issue on my laptop’s display out of the dock. So I wanted to see if it’s the dock and pulled the laptop out, and connected just one external monitor directly to the USB/HDMI port. Started with mirrored displays, worked fine - though not super sharp due to the different resolutions. Switched to extended screen - and the bleeding/blurring with mouse movements were back - so it’s not directly the Display Link drivers of the USB dock that run my three external monitors. Put the laptop back into the dock, resumed from sleep wakening up all monitors - and to my surprise, the bleeding is gone.

Since it works again for me, I don’t have time to do further testing for now.

My only hunch is that on reconnect and having triggered different display profiles in between, windows created a new display configuration entry in the registry and set something different from before. I should add that I run a high-end laptop with two graphic cards, where different devices and apps are served by either of them depending on performance needs.

1 Like

Thanks for trying to debug the issue, if you’re up for it you may want to create an issue here to track the problem:

Just wanted to report it’s back again today - tried to start over and delete all my GraphicsDrivers/Configuration and GraphicsDrivers/Connectivity keys and rebooted, but to no avail. Flutter shows some real rendering flutter … how ironic :wink:

Ok - this time I think I got it … I hope!
Disabled the 3D setting for my NVIDEA RTX A2000 and forced to use the internal Intel UHD graphics chip - and all the blurring/bleeding/fluttering is gone.
I’ll see if I can install a different driver version for the NVIDEA or play with the 3D setting to find out what the issue is. Anyway, it may not be flutter, and definitely not you guys problem. Sorry for the lengthy thread here but maybe it helps someone else down the road.

1 Like

Awesome, thanks for sharing the solution!