Solved: Approving Quote results in non https page

So sent a test quote.
Went to approve test quote via portal and I am redirected to a page (chrome) stating the form is not secure. Address bar is not using https. When hitting send anyway, I am redirected back to a secure https page. Any reason why I am hitting this non https page?

Additional Info: is being access through Nginx reverse proxy docker. I have added the following to the config without any success also

proxy_set_header Host $host;
proxy_set_header X-Real-IP $remote_addr;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_set_header X-Forwarded-Proto $scheme;
proxy_redirect off;

also tried just

AddHeader “X-Forwarded-Proto: https”

any way I can have my NRP connect straight to the app instead of using the built in proxy that comes with the docker compose?


Thanks for reporting this!

@ben any thoughts?

Hey there,

Can you check your .env file for the following variables: APP_URL, REQUIRE_HTTPS?



I didn’t have the require https. But when enabled I couldn’t access https or http.
Edited the docker-compose to add the https ports. that didn’t work either.

I have the same problem…

Updated original post with more info about my proxy

have you set trusted proxies in the .env file?

Yes sir. Tried the whole subnet(local) and direct IP. Have not tried the external IP. Just thought of that.

Alright. After playing around some more. Working now.

I set
TRUSTED_PROXIES='' being the subnet for invoiceninja network that is created by the docker-compose.
Another side affect is this also fixed PDF generation for quotes from external access. Was going to make another post for that once this was finished. Now I can purchase the branding license and really get going with IN. Thank you to @david and @ben and others this week for the help in my few topics.

1 Like

See my last reply (marked as solution)