Signature generating error on approve


I’m on self hosted version 4.5.17 but I can’t get the signature system to work.

I get following message after signing and approving the quote/invoice:

Failed to load resource: the server responded with a status of 405 (Method Not Allowed)

Anyone encountered the same problem?

Hi, are there any details in storage/logs/laravel-error.log or the web server error logs?

No, nothing at all but I discovered an error in the log file that makes me think that I maybe didn’t do the update like I should.

He’s trying to reach a column that doesn’t exist.

How can I update the database without losing data?

I only copied the documents of the latest version over my 4.5.16 version and nothing else.

Do you have SSH access? You can run the database migrations using php artisan migrate, otherwise you can load /update in the browser.

No SSH access and /update isn’t an option.
I’m using Invoice Ninja on a shared hosting, so I don’t have the rights to perform anything I want and /update needs some rights that I don’t have

Isn’t there an update script that I could run?

Umm… yes, it’s run using /update

Assuming you can’t get SSH access or the permissions enabled one workaround is to copy your database to your local environment, run the migration and then copy it back.

Is there a difference between the 4.5.16 DB and the 4.5.17 DB?

No, but my guess would be the database migration failed with a past release

In that case the problem isn’t related to the DB.
I’ll try a fresh install to check if it’s related to my installation or to the version

I believe I’ve seen this problem in the past, if the database migration hasn’t run the feature fails to work because it depends on the table field to track the value.

One solution would be to setup a new install and transfer the data as JSON, this isn’t ideal though as it isn’t a complete transfer. Alternatively you could copy the database to a system where you have command line access to work through the migrations.

I’m thinking about moving my data to a VPS so I can get more access than I get now but the problem remains, I still get the 405 error when I try to accept a quote.

I’ve seen somewhere that you suggested that it might be permissions related but for another problem but with the same error message, couldn’t this be the same problem?

We’ve sometimes seen server mod security rules causes issues.

It may help to check that the migrations table is up to date with this list

Thanks for the tip Hillel!

I don’t think the DB has changed between version 4.5.16 and 4.5.17 (based on your URL), so we can exclude that.

What can be the reason the system won’t accept the signature?

Would it be my fault (hosting) or your fault (coding) ?

Which version are you upgrading from? Was the feature working before you upgraded?

I had 4.5.16 and I uploaded the files of 4.5.17.

I can’t really answer that question because I saw that option only after upgrading to 4.5.17.

I’ve installed the 4.5.16 version locally (through wamp64) but I get the same error.

When testing locally was it a clean install or did you use your database backup?

I did a clean install based on a copy of the 4.5.16 zip file

Are you still seeing the 405 error? Can you reproduce the problem?