Setup Loop & error 500 Main page

I recently installed invoiceninja on my ubuntu VPS using apache, I havent used the docker version. I can navigate to /setup fine and run the setup but it just reloads the 1st page after ive completed it. If i go to i get error 500. Attached is my laravel.log, if any other logs are needed comment and ill send them as im not sure what else may be needed!

Laravel Log:

Hey there, thanks for reporting this. I’ll need you to be more explicit.
After you complete the setup, you should be redirected to login page.

Maybe you can turn on debugging mode & see what’s wrong:

  1. Edit .env file (in Invoice Ninja folder)
  2. Edit APP_DEBUG=true
  3. Run: php artisan optimize

Now you should be able to see the erorr. Don’t forget to set it to false & optimize again, as this debug mode can expose some private info to public. Thanks

Dont it and it says “SQLSTATE[42S02]: Base table or view not found: 1146 Table ‘ninja.accounts’ doesn’t exist (SQL: select * from accounts limit 1)”

But im not sure why its doing this? its just a blank database, shouldnt the setup add all the tables etc? That errors from going to the domain itself. I also dont get a login page, the setup just repeats, if i forcibly go to i get error 500

I have exactly the same issue on a Debian10 install. Seems like I get every error possible for my v5 adventure. :slight_smile:

I dont understand why tho. any website ive installed before sets up the database tables itself. this one by the sounds of it hasnt

I try to migrate/install v5 since yesterday and have some weird issues. v4 was easy to install, but I have no idea what is going on here. But, I am here to help as good as possible, as I really like invoiceninja.

(sorry I couldn’t reproduce the 500 error from yesterday, as I wasn’t able to post more as a new member here)

1 Like

In first my problem seemed to align with the topic starter, later found out that the error output was different so I started my own topic.

Hi There,

Can you please check the errors in the logs storage/logs/laravel.log

The errors are the same as linked in the first post.

What happens if you run php artisan migrate:fresh --seed

from the command line?

This fixed mine, just had to sort an issue with it redirecting but now it all works!
Thanks :slight_smile:

This happened to me - I ran “php artisan migrate” from a terminal to sort it out.

same here now its fixed :slight_smile:

Thanks a lot! That worked. I am able to login now.

Up next: Error 403 when inside PDF templates. But there is another thread for that.