Server 500 Error after Softaculous Update to 5.5.54

I was previously running v5 on my shared hosting account without issue. Softaculous stated there was an outstanding update to 5.5.54 to be done, so I went ahead and performed the update. The installer stated the update completed successfully and I am able to view the login page, however when I attempt to login I just get a “500 Server Error”. I contacted the hosting company who checked the PHP settings and logs and could not find any issue and state nothing is present in the logs as far as errors. Is there any other steps I can perform to resolve the issue? Tax time is coming and I need to get my reports.


Are there any errors in the application logs in storage/logs?

Hi hillel,

Thanks for the quick reply. The only thing present is the laravel.log and the only things with today or yesterdays date (when I did the update) are the following entries. I should also note that when I attempt to login, I get the 500 Server Error, but I do receive an e-mail stating there has been a new login to Invoice Ninja from my IP so it seems to register the attempt.

[2023-01-17 02:14:02] production.ERROR: strtolower(): Passing null to parameter #1 ($string) of type string is deprecated {“exception”:"[object] (ErrorException(code: 0): strtolower(): Passing null to parameter #1 ($string) of type string is deprecated at /home/cpanelusername/myURL/vendor/swiftmailer/swiftmailer/lib/classes/Swift/Transport/EsmtpTransport.php:144)
#0 [internal function]: Illuminate\Foundation\Bootstrap\HandleExceptions->handleError()
#1 /home/cpanelusername/myURL/vendor/swiftmailer/swiftmailer/lib/classes/Swift/Transport/EsmtpTransport.php(144): strtolower()
#2 /home/cpanelusername/myURL/vendor/swiftmailer/swiftmailer/lib/classes/Swift/SmtpTransport.php(43): Swift_Transport_EsmtpTransport->setEncryption()
#3 /home/cpanelusername/myURL/vendor/laravel/framework/src/Illuminate/Mail/MailManager.php(194): Swift_SmtpTransport->__construct()
#4 /home/cpanelusername/myURL/laravel/framework/src/Illuminate/Mail/MailManager.php(178): Illuminate\Mail\MailManager->createSmtpTransport()
#5 /home/cpanelusername/myURL/vendor/laravel/framework/src/Illuminate/Mail/MailManager.php(152): Illuminate\Mail\MailManager->createTransport()
#6 /home/cpanelusername/myURL/vendor/laravel/framework/src/Illuminate/Mail/MailManager.php(120): Illuminate\Mail\MailManager->createSwiftMailer()
#7 /home/cpanelusername/myURL/vendor/laravel/framework/src/Illuminate/Mail/MailManager.php(95): Illuminate\Mail\MailManager->resolve()
#8 /home/cpanelusername/myURL/vendor/laravel/framework/src/Illuminate/Mail/MailManager.php(73): Illuminate\Mail\MailManager->get()
#9 /home/cpanelusername/myURL/vendor/laravel/framework/src/Illuminate/Mail/MailManager.php(550): Illuminate\Mail\MailManager->mailer()
#10 /home/cpanelusername/myURL/app/Providers/MailServiceProvider.php(31): Illuminate\Mail\MailManager->__call()
#11 /home/cpanelusername/myURL/vendor/laravel/framework/src/Illuminate/Container/BoundMethod.php(36): App\Providers\MailServiceProvider->boot()
#12 /home/cpanelusername/myURL/vendor/laravel/framework/src/Illuminate/Container/Util.php(40): Illuminate\Container\BoundMethod::Illuminate\Container\{closure}()
#13 /home/cpanelusername/myURL/vendor/laravel/framework/src/Illuminate/Container/BoundMethod.php(93): Illuminate\Container\Util::unwrapIfClosure()
#14 /home/cpanelusername/myURL/vendor/laravel/framework/src/Illuminate/Container/BoundMethod.php(37): Illuminate\Container\BoundMethod::callBoundMethod()
#15 /home/cpanelusername/myURL/vendor/laravel/framework/src/Illuminate/Container/Container.php(653): Illuminate\Container\BoundMethod::call()
#16 /home/cpanelusername/myURL/vendor/laravel/framework/src/Illuminate/Foundation/Application.php(914): Illuminate\Container\Container->call()
#17 /home/cpanelusername/myURL/vendor/laravel/framework/src/Illuminate/Foundation/Application.php(895): Illuminate\Foundation\Application->bootProvider()
#18 [internal function]: Illuminate\Foundation\Application->Illuminate\Foundation\{closure}()
#19 /home/cpanelusername/myURL/vendor/laravel/framework/src/Illuminate/Foundation/Application.php(896): array_walk()
#20 /home/cpanelusername/myURL/vendor/laravel/framework/src/Illuminate/Foundation/Bootstrap/BootProviders.php(17): Illuminate\Foundation\Application->boot()
#21 /home/cpanelusername/myURL/vendor/laravel/framework/src/Illuminate/Foundation/Application.php(237): Illuminate\Foundation\Bootstrap\BootProviders->bootstrap()
#22 /home/cpanelusername/myURL/vendor/laravel/framework/src/Illuminate/Foundation/Console/Kernel.php(310): Illuminate\Foundation\Application->bootstrapWith()
#23 /home/cpanelusername/myURL/vendor/laravel/framework/src/Illuminate/Foundation/Console/Kernel.php(127): Illuminate\Foundation\Console\Kernel->bootstrap()
#24 /home/cpanelusername/myURL/artisan(37): Illuminate\Foundation\Console\Kernel->handle()
#25 {main}

Then there are several lines of the following which follow the above entries which are also repeated a few times:

[2023-01-17 02:27:10] production.INFO: db fails
[2023-01-17 02:27:52] production.INFO: db fails

Thanks for the help!

This happened to me too when I tried to update my installation with Softaculous to 5.5.54 a few days ago. For some reason, a manual update to 5.5.55 on top of that failed too (Error 500). I ended up just reinstalling everything from the latest from GitHub and copying over my .env file and my ./public/storage folder from the previous installation and now it works.

This is not a fix for the issue and more like a workaround, I know, but still, this is how getting things back running again can be done quickly :slightly_smiling_face:

1 Like

@david have you seen this error before?

I don’t think the update is working at all. I can see from the class that is throwing the error (swiftmailer) it did not exist in 5.5.54, so most likely the system did not overwrite/update the files at all.

Thanks for the reply. Would the recommended course of action in this case then be to do what @charles described above?


Other users have reported that simply overwriting the current installation with the files from the release section on github resolves the update issue.

Thank you. So I downloaded 5.5.54 from github and uploaded all the files to my installation via FTP, overwriting any existing ones. I then copied over a backup of the .env file. Upon reload of the site and attempting to login, I get the same “500 server error”. I checked laravel.log and there are no new entries present.

You’ll want to put the app into debug mode (APP_DEBUG=TRUE in your .env)

Then update the cache /update?secret=secret and see the output of the exact error message.

1 Like

I checked and the APP_DEBUG was already set to “true” but no new entries were present in the log. However, after running /update?sercret I was able to log back in and it appears things are working again and I have access to my data. I have another question unrelated to this issue so I’ll open a new topic for it after checking if there is an existing reported issue for it.

Thanks for the help, it’s greatly appreciated!

As a follow-up to OP’s issue, on my end I tried the .56 update with Softaculous tonight and it gave me an error 500 again. The last 3 updates from Softaculous were not working for some reason, but the error is different from OP.

When trying to run artisan optimize I get this:

I’m pretty sure it’s the same error as the last versions for me.

laravel.log points to the same issue:

[2023-01-19 03:03:13] production.ERROR: Class "Barryvdh\Debugbar\ServiceProvider" not found {"exception":"[object] (Error(code: 0): Class \"Barryvdh\\Debugbar\\ServiceProvider\" not found at /home/charleso/public_html/admin/vendor/laravel/framework/src/Illuminate/Foundation/Application.php:754)
#0 /home/charleso/public_html/admin/vendor/laravel/framework/src/Illuminate/Foundation/Application.php(686): Illuminate\\Foundation\\Application->resolveProvider('Barryvdh\\\\Debugb...')
#1 /home/charleso/public_html/admin/vendor/laravel/framework/src/Illuminate/Foundation/ProviderRepository.php(75): Illuminate\\Foundation\\Application->register('Barryvdh\\\\Debugb...')
#2 /home/charleso/public_html/admin/vendor/laravel/framework/src/Illuminate/Foundation/Application.php(666): Illuminate\\Foundation\\ProviderRepository->load(Array)
#3 /home/charleso/public_html/admin/vendor/laravel/framework/src/Illuminate/Foundation/Bootstrap/RegisterProviders.php(17): Illuminate\\Foundation\\Application->registerConfiguredProviders()
#4 /home/charleso/public_html/admin/vendor/laravel/framework/src/Illuminate/Foundation/Application.php(242): Illuminate\\Foundation\\Bootstrap\\RegisterProviders->bootstrap(Object(Illuminate\\Foundation\\Application))
#5 /home/charleso/public_html/admin/vendor/laravel/framework/src/Illuminate/Foundation/Console/Kernel.php(383): Illuminate\\Foundation\\Application->bootstrapWith(Array)
#6 /home/charleso/public_html/admin/vendor/laravel/framework/src/Illuminate/Foundation/Console/Kernel.php(153): Illuminate\\Foundation\\Console\\Kernel->bootstrap()
#7 /home/charleso/public_html/admin/artisan(37): Illuminate\\Foundation\\Console\\Kernel->handle(Object(Symfony\\Component\\Console\\Input\\ArgvInput), Object(Symfony\\Component\\Console\\Output\\ConsoleOutput))
#8 {main}

It looks like something was corrupted by the Softaculous update, because I could not fix the issue by reforcing the update by unzipping the .56 source code on top of it. I had to revert back to .55 from a backup and then manually update (and I guess a full overwrite would have worked, too).